It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

"complete sprint" button grayed out for the board Owner?

We have configured board (test board) for only one project(test project)

User is the Owner of the Board(test board) and admin of the project(test project)

but user is not able to complete the sprint because "complete sprint"  option is grayed out  ,what could be the reason please suggest on the earliest.


we are  using JIRA 7.2.2 recently upgraded.


7 answers

Could you check:

  1. If there is a tooltip giving additional information if you hover over the button
  2. If the user has the Manage Sprints permission in your project
  3. (if that didn't fix the problem), what the JQL filter behind the board is
  4. If you are using subtasks in your project

#3 was the issue for me.

I had to tweak the JQL to use a less loose criteria.

Instead of using "Epic Name" = "MYEPIC", I just used something like key = "ISSUE_KEY"

For people trying to figure this out see Walter's other post on Nov 12, 2018.

In my case, the board/sprint JQL filter had an additional project (other than the base one) where the I did not have "Manage Sprint" permissions.

#1 helped :) thanks!

I am also facing the same issue.  Getting problem for one specific board only

Is there any luck?



I suspect one or more of Walter's points solved it when investigated.

ok. I will check thoroughly 

I am getting this tooltip msg "You need the Manage Sprints permission for all projects in the origin board to manage this sprint. "


I checked managed sprint permission. It has already given to that user.


"Complete Sprint" is disabled for "Users" who are project admin, filter admin/owner, also having "Manage Sprint" permissions, however it enabled only for "JIRA-Administrators"???


We recently upgraded JIRA version from 6.4.5 to 7.6.4.

Same issue here in JIRA Data Center 7.6.7.  Getting the same error where only JIRA System Administrators are able to close the sprint.

I don't know if this is true for your specific case, but often the JQL filter used to retrieve the data for your board is the cause.

If your filter is based on flexible criteria, Jira does not know what projects may be returned in the backlog and more or less requires you to grant manage sprints permission to all jira projects on your instance. With 'flexible criteria', I mean generic clauses like:

Component = Infrastructure


assignee in membersof("My Team")


"Epic link" IS NOT EMPTY

or an unwanted JQL glitch like this, where a lot of data are added to the result by accident:

(project in (A, B, C) AND Resolution = Unresolved) OR (Resolved > -30d)

In most cases you will probably not like to grant the 'Manage Sprints' permission to a bunch of people on all projects. So if you recognise this, see whether you can find a way to make the projects in your backlog explicit in your board filter. 

Thanks for your info.


But in the same board and project we have 4 sprints

Out of 4 sprints , we are to get the "complete sprint" option for 3 sprints but not for other one.

we are using the same project and same board for all 4 the sprints .out of 4 sprints 3 are good why the remanaing one

Hi Sindhu,

Thanks for providing some additional info. As I can't see your specific situation, have a close look at what is different in this 1 sprint in comparison to the others:

  • Are there any issues from a different project, maybe with different permissions
  • If you are using subtasks, check if haven't closed any issues having incomplete subtasks associated with them
  • Anything else that is specific to this sprint in comparison with the others


I had the same issue recently with one project and exhausted all the standard checks.  

What it turned out to be was the project key had been changed at some point, but the filter driving the Sprint board still used the old project key.

This is why changing a project key is so risky - the old key never disappears, creating lots of opportunities for confusion.

Another possibility, which we are experiencing just now, is the browser not properly refreshing the board page after assigning the 'Manage Sprint' permission with a Project Role. Meanwhile, they are able to 'Complete Sprint' with a different browser as workaround. That function is overly sensitive, from I found over the years. 

I discovered another possible cause of this today; bear with me as it's a little convoluted.

Someone creates a Sprint Board (not attached to a project) with a JQL filter that spans more than one project.  Sprints created in this board therefore span multiple Jira Projects.

However, these Sprints also appear in each of those individual Jira Projects, in their native Sprint and Backlog boards.  To close this Sprint, you'd need Manage Sprint permission in all projects (which is what the tooltip error tells you).

But it's a tricky one to troubleshoot, as you'd naturally go to the Board configuration in the individual project where a user is having the problem, and see only one board in the filter.

What you need to do is get the Sprint ID (see and then look it up with the following:

select "ID","NAME","RAPID_VIEW_ID" from "AO_60DB71_SPRINT" where "ID"= <ID of SprintA>;

If the RAPID_VIEW_ID isn't the same as the board the user's looking at (check secure/RapidBoard.jspa?rapidView=<board id>), then there's your problem!  Go to the board ID returned in the query and start troubleshooting from there.

Suggest an answer

Log in or Sign up to answer

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you