"Content by Label" Macro is not working correctly

We have pages that are aggregates of other pages, for instance a page about a software version that uses labels features v3-2 bugs and jira-tickets to show links to pages specific to that version. The Content by label macro does not appear to show all the pages that have that label applied. Also, perhaps related, the global page search does not appear to work either - searching for an exact title of a page will bring up zero results. In both cases, the functionality sometimes works, sometimes doesn't.

I've rebuild the search index, but to no avail. Also, a restart appears to bring back this functionality temporarily.

1 answer

3 votes

Hi Matt,

I truly suspect that this behavior is caused by a corrupted index. have you tried to rebuild the index from scratch as well? http://confluence.atlassian.com/display/DOC/Rebuild+the+Content+Indices+from+scratch

if the issue persists, please verify if Confluence is not running out of memory (RAM) or out of memory in the server HD space. This can cause index to fail too.

Hope that helps!

Regards,

Rodrigo

The manual rebuild of the index appears to have solved the problem. One month has gone by and this hasn't recurred. Thanks!

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,401 views 15 19
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you