Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

prohibit transfer to work if the field value is not set

Sorry for my english.

I have project and modified workflow so that user must at first setup custom field "story points estimates" and then he can move task to "In progress"

But I can't understand. If I try to move task "to do" -> "in progress" without fullfill field I can see such error Untitled.png

I see, that I can't move task, but also I can do it. How I can remove middle element.

 

Also I can move task to "in progress" by drop down menu in task. How I can disable this too?

1 answer

1 accepted

0 votes
Answer accepted
Chris Buzon Community Leader Apr 12, 2021

hey Aleksey,

I think you're using a next-generation project based on the screenshot, which currently doesn't have any way to enforce required fields before status transitions.

In order to do this through the workflow (a conditional or validator will work for that) you would need to move to a classic project.

What you can do (and I don't suggest this, but it can be done) is use automation rules to move tickets back in the workflow if they're missing info, or to send a message to someone when the data is missing and the ticket has been moved.


sorry for my english.

It was my bug) I forgot about default transaction from any statuses. I deleted it and now it is working very well.

 

Screenshot_2021-04-13_11-10-42.png

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you