issue in parent("assignee = currentUser")

I've been trying to use this but with a custom field. It keeps on returning an error:

“Invalid JQL Query in function: parent”

Is it impossible to use a custom field with this function?

1 answer

1 accepted

0 vote

What do you mean by "use with a custom field"?

Are you able to run this query in issue navigator?

When I use

issue in parent("*Customfield* is not empty") I get the error. It seems to be only working for system default fields.

It should work fine. Are you using the custom field name? If so, make sure to escape double quotes if there is space in the name. Something like:

issue in parent("\"Custom field\" is not empty")

If it still doesn't work, are there any error in the logs?

Thank you Jobin! It worked. I didn't use \" as the escape since it was indivated in the documentation to use *. Thank you very much for this!

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Sunday in Agility

You asked for it, so we delivered: images on issues have arrived

A picture tells a thousand words. And agility boards have just released their latest feature: cover images on issues – so now your board can tell a story at first glance. Upload attachmen...

184 views 1 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you