maxResults is not working in jql search query Edited

I have an API in below form

 

https://companyName.atlassian.net/rest/api/2/search/?jql=project=abc AND (status changed to (closed,"Deployed to Prod") AFTER startOfMonth(-1) BEFORE endOfMonth(-1)) AND "Team" = "ABC" AND issuetype not in(subTaskIssueTypes(),Epic) &maxResults=1000

 

total no of results are for this issue query is 150 but in response, I am getting only 100. 

 

in response, I get something like this,

 

{
"expand": "schema,names",
"startAt": 0,
"maxResults": 100,
"total": 150,
"issues": [
{

I don't know what the mistake I am doing here. Can anybody please help me

1 answer

This widget could not be displayed.
Warren Levy Community Champion Sep 20, 2017

Hi Saurabh

Please see this post - Atlassian have unfortunately made a change and not told anyone

Thanks Warren for letting me know about this.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted 3 hours ago in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

13 views 0 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you