jira 6.05 start error

jira6.05 centos6.5  tomcat7  jdk7 mysql5.6

start tomcat...

2014-11-12 08:15:16,103 localhost-startStop-1 INFO      [atlassian.plugin.manager.DefaultPluginManager] Initialising the plugin system
2014-11-12 08:15:20,245 localhost-startStop-1 INFO      [atlassian.plugin.loaders.ScanningPluginLoader] No plugins found to be deployed
2014-11-12 08:15:20,595 localhost-startStop-1 ERROR      [plugin.osgi.factory.OsgiPlugin] Detected an error (BundleException) enabling the plugin 'com.atlassian.activeobjects.activeobjects-plugin' : Unresolved constraint in bundle com.atlassian.activeobjects.activeobjects-plugin [32]: Unable to resolve 32.0: missing requirement [32.0] package; (&(package=javax.servlet)(version>=2.4.0)).  This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see https://developer.atlassian.com/x/mQAN
2014-11-12 08:15:20,596 localhost-startStop-1 WARN      [plugin.osgi.factory.OsgiPlugin] Unable to enable plugin 'com.atlassian.activeobjects.activeobjects-plugin'
2014-11-12 08:15:20,597 localhost-startStop-1 WARN      [plugin.osgi.factory.OsgiPlugin] Because of this exception
com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.activeobjects.activeobjects-plugin
    at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:483)
    at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:273)
    at com.atlassian.plugin.impl.AbstractDelegatingPlugin.enable(AbstractDelegatingPlugin.java:226)
    at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:116)
    at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:101)
    at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:805)
    at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:241)
    at com.atlassian.jira.plugin.JiraPluginManager.start(JiraPluginManager.java:62)
    at com.atlassian.jira.ComponentManager$PluginSystem.start(ComponentManager.java:680)
    at com.atlassian.jira.ComponentManager.startJIRA(ComponentManager.java:218)
    at com.atlassian.jira.ComponentManager.quickStart(ComponentManager.java:212)
    at com.atlassian.jira.ComponentManager.start(ComponentManager.java:197)
    at com.atlassian.jira.upgrade.PluginSystemLauncher.start(PluginSystemLauncher.java:23)
    at com.atlassian.jira.startup.DefaultJiraLauncher$3.run(DefaultJiraLauncher.java:115)
    at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrEnqueue(DatabaseConfigurationManagerImpl.java:315)
    at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrWhenDatabaseActivated(DatabaseConfigurationManagerImpl.java:209)
    at com.atlassian.jira.startup.DefaultJiraLauncher.postDbLaunch(DefaultJiraLauncher.java:105)
    at com.atlassian.jira.startup.DefaultJiraLauncher.access$100(DefaultJiraLauncher.java:30)
    at com.atlassian.jira.startup.DefaultJiraLauncher$1.run(DefaultJiraLauncher.java:69)
    at com.atlassian.jira.util.devspeed.JiraDevSpeedTimer.run(JiraDevSpeedTimer.java:33)
    at com.atlassian.jira.startup.DefaultJiraLauncher.start(DefaultJiraLauncher.java:64)
    at com.atlassian.jira.startup.LauncherContextListener.contextInitialized(LauncherContextListener.java:54)
    at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4994)
    at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5492)
    at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
    at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1575)
    at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1565)
    at java.util.concurrent.FutureTask.run(FutureTask.java:262)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    at java.lang.Thread.run(Thread.java:745)
Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.activeobjects.activeobjects-plugin [32]: Unable to resolve 32.0: missing requirement [32.0] package; (&(package=javax.servlet)(version>=2.4.0))
    at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:1709)
    at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905)
    at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892)
    at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:459)
    ... 30 more
2014-11-12 08:15:20,599 localhost-startStop-1 ERROR      [atlassian.plugin.manager.PluginEnabler] Unable to enable plugin com.atlassian.activeobjects.activeobjects-plugin
com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.activeobjects.activeobjects-plugin
    at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:483)
    at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:273)
    at com.atlassian.plugin.impl.AbstractDelegatingPlugin.enable(AbstractDelegatingPlugin.java:226)
    at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:116)
    at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:101)
    at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:805)
    at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:241)
    at com.atlassian.jira.plugin.JiraPluginManager.start(JiraPluginManager.java:62)
    at com.atlassian.jira.ComponentManager$PluginSystem.start(ComponentManager.java:680)
    at com.atlassian.jira.ComponentManager.startJIRA(ComponentManager.java:218)
    at com.atlassian.jira.ComponentManager.quickStart(ComponentManager.java:212)
    at com.atlassian.jira.ComponentManager.start(ComponentManager.java:197)
    at com.atlassian.jira.upgrade.PluginSystemLauncher.start(PluginSystemLauncher.java:23)
    at com.atlassian.jira.startup.DefaultJiraLauncher$3.run(DefaultJiraLauncher.java:115)
    at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrEnqueue(DatabaseConfigurationManagerImpl.java:315)
    at com.atlassian.jira.config.database.DatabaseConfigurationManagerImpl.doNowOrWhenDatabaseActivated(DatabaseConfigurationManagerImpl.java:209)
    at com.atlassian.jira.startup.DefaultJiraLauncher.postDbLaunch(DefaultJiraLauncher.java:105)
    at com.atlassian.jira.startup.DefaultJiraLauncher.access$100(DefaultJiraLauncher.java:30)
    at com.atlassian.jira.startup.DefaultJiraLauncher$1.run(DefaultJiraLauncher.java:69)
    at com.atlassian.jira.util.devspeed.JiraDevSpeedTimer.run(JiraDevSpeedTimer.java:33)
    at com.atlassian.jira.startup.DefaultJiraLauncher.start(DefaultJiraLauncher.java:64)
    at com.atlassian.jira.startup.LauncherContextListener.contextInitialized(LauncherContextListener.java:54)
    at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4994)
    at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5492)
    at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
    at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1575)
    at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1565)
    at java.util.concurrent.FutureTask.run(FutureTask.java:262)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    at java.lang.Thread.run(Thread.java:745)
Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.activeobjects.activeobjects-plugin [32]: Unable to resolve 32.0: missing requirement [32.0] package; (&(package=javax.servlet)(version>=2.4.0))
    at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
    at org.apache.felix.framework.Felix.startBundle(Felix.java:1709)
    at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905)
    at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892)
    at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:459)
    ... 30 more
2014-11-12 08:15:20,719 localhost-startStop-1 ERROR      [plugin.osgi.factory.OsgiPlugin] Detected an error (BundleException) enabling the plugin 'com.atlassian.crowd.embedded.admin' : Unresolved constraint in bundle com.atlassian.crowd.embedded-crowd-admin-plugin [37]: Unable to resolve 37.0: missing requirement [37.0] package; (&(package=javax.servlet)(version>=2.3.0)).  This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see https://developer.atlassian.com/x/mQAN
2014-11-12 08:15:20,719 localhost-startStop-1 WARN      [plugin.osgi.factory.OsgiPlugin] Unable to enable plugin 'com.atlassian.crowd.embedded.admin'
2014-11-12 08:15:20,719 localhost-startStop-1 WARN      [plugin.osgi.factory.OsgiPlugin] Because of this exception
com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.crowd.embedded.admin

 

 

3 answers

0 votes

Sounds like your classpath includes extra copies of plugins, or an invalid one that is breaking the others.

How have you installed the system, and what have you changed away from the default installation?

ok my Installation steps...

down   atlassian-jira-6.0.5-war.tar.gz   and  unzip  it.       and then ,  put    webapp 's files  into   tomcat7's webapps.

and down  jars   eg:jta-1_1.jar  jotm-core-2.1.4.jar.       and then  start tomcat。  and then 。。。error

0 votes

Well, that's pretty much wrong then.

Why are you downloading random jars and installing them?  There's a neat package of the ones you actually need (and the right versions) referenced in the installation instructions,.  There's no mention of the process you should be doing in your description - what are you doing to build the the WAR and no mention of installing the database drivers.

Could you step through https://confluence.atlassian.com/display/JIRA/Installing+JIRA+on+Tomcat+6.0+or+7.0 and check you have followed each line properly?

database intall success ,and init success。 all tables in database。

 

 

 

2014-11-12 08:15:14,118 localhost-startStop-1 INFO      [core.entity.jdbc.DatabaseUtil] Database Product Name is MySQL

2014-11-12 08:15:14,118 localhost-startStop-1 INFO      [core.entity.jdbc.DatabaseUtil] Database Product Version is 5.6.20-log

2014-11-12 08:15:14,118 localhost-startStop-1 INFO      [core.entity.jdbc.DatabaseUtil] Database Driver Name is MySQL Connector Java

2014-11-12 08:15:14,119 localhost-startStop-1 INFO      [core.entity.jdbc.DatabaseUtil] Database Driver Version is mysql-connector-java-5.1.25 ( Revision: ${bzr.revision-id} )

2014-11-12 08:15:14,596 localhost-startStop-1 INFO      [atlassian.jira.startup.DatabaseChecklistLauncher] JIRA database startup checks completed successfully.

2014-11-12 08:15:14,596 localhost-startStop-1 INFO      [jira.config.database.DatabaseConfigurationManagerImpl] Now running Post database-configuration launchers

2014-11-12 08:15:14,986 localhost-startStop-1 INFO      [jira.config.database.SystemDatabaseConfigurationLoader] Reading database configuration from /opt/jira_home/dbconfig.xml

2014-11-12 08:15:15,295 localhost-startStop-1 INFO      [atlassian.jira.startup.DatabaseLauncher] Database transactions enabled: true

2014-11-12 08:15:15,296 localhost-startStop-1 INFO      [atlassian.jira.startup.DatabaseLauncher] Using JIRA's default for database transaction isolation level: 2

2014-11-12 08:15:15,297 localhost-startStop-1 INFO      [atlassian.jira.startup.JiraStartupLogger]

 

Database configuration OK

 

 

     Loading entityengine.xml from                 : file:/usr/local/tomcat7jira/webapps/jira/WEB-INF/classes/entityengine.xml
     Entity model field type name                  : mysql
     Entity model schema name                      :
     Database Version                              : MySQL - 5.6.20-log
     Database Driver                               : MySQL Connector Java - mysql-connector-java-5.1.25 ( Revision: ${bzr.revision-id} )
     Database URL                                  : jdbc:mysql://192.168.1.168:3306/jiradb?useUnicode=true&characterEncoding=UTF8&sessionVariables=storage_engine=InnoDB
     Database JDBC config                          : mysql jdbc:mysql://192.168.1.168:3306/jiradb?useUnicode=true&characterEncoding=UTF8&sessionVariables=storage_engine=InnoDB

But what are you doing differently from the documentation?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 18, 2018 in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

26,802 views 2 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you