jemh ignores attachments

Hello, it's the desperate jira-novice again. ;)

The setup:

  • jemh v1.5.48 with a profile configured to map certain mails to specific projects.
  • issue-creation and commenting via mail work just fine
  • projects in question use security sheme where "add attachment" is allowed to jiras group "Anyone"
  • jira allows attachments

The problem:

  • no attachments are added whatsoever, though jemh does see them

Example Mail Content from jemh audit log:

This is a multi-part message in MIME format.
--------------010303010001040508070206
Content-Type: text/plain; charset=UTF-8; format=flowed
Content-Transfer-Encoding: 7bit

mail text here

--------------010303010001040508070206
Content-Type: image/png;
 name="logo.png"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
 filename="ariva_logo.png"

iVBORw0KGgoAAAANSUhEUgAAAJkAAAAeCAMAAAAIN0zoAAAABGdBTUEAALGPC/xhBQAAAJlQ
TFRFAAAAjgAQGAAAMQAIvQAQIQAAewAQSgAIxgAYzgAYrQAQ1gAYawAIEAAACAAAWgAI5xgp
5yk9e3t75wgh6zVKc3Nza2trlJSU71pr5xwxVlZW5xAphISE/+/3GBgY63uHPT09KSkpEBAQ
Y2Nj/+Tm98DGpKSk8/PzjIyMwcHB4uLi70FWCAgISkpK95Cc//f3////3gAYAAAALjSJ2QAA
AAF0Uk5TAEDm2GYAAAO5SURBVFjDtZjZdpswEIbTPW3TJF4JOAaDzWoBMu//cNVopNEIO2k4
PcxFAMGIL79mEb6780zWx1QMc9if35cP22qRnMZc6TCXPVwmWeihlcfZuIbH+2lklxcOdpgP
bHiaCHYJHVjfzgg2fP0Pstc5wX5MBWOrWWZ8praqKod6qJwtI527GZzHw1b9peg8wlh67a7s
F7ws6ciStQXoPHshsvwNyVopZUlXqeTW6JfX6kQxq+uCyNRFcMN9GL7olyV8ljy8HpOSyBaS
JIs5WNZ4U7/67q8G9ohkgXkqbizlyN1Idjl5s+QojTd2WlmyjiQLOJio4bGeOEv1yhYN7lRq
rFCSCY8McGrh3BnZN1w40OQMlmhGEO2sjsmZbEHx31NipiOwnpFt1HnMljlSkqn7G3NZkVOt
Y1UU2p2RfbLy5ObFO0Bb+GOeOckKLpmauagdmWhYLAWolTrolGnN4qKIsT2rlXtJXe6zfhnI
c6b4Rs3WPLSYPe+pLXHJAlgVRgaBbe+3SoytCqnSAEUStdPE+FBl3Yns+1gyfXFyhytLSLKa
galwb7KBkSnJmqO2TWFSUT2DKQNkinRYqgFsIUtyF14v9+TZqX+wUwmoDvuTtnzHwHbUNCXr
S1tcFUcW+YlZCEyJgG4etaymhTB34fXyjmce1Iq1HrPW/VOyqJdlikIZsppz1a1NiZTIIr3G
0ZW7IXv8qeuTeiShXc5Jr2wIkhlb8E2Qk8x1THhHAAtXWjKoC9V2u4WFDOJxSiiJZHsoTbAN
LdQXcGdkT+9Jtn9+tzE5yeAdZP3gar1X7VlKbCDOGpufvrshu8f6xCRbY5Tt9qNFtOa2ZhF1
IVAKDeYeXK1X6SgNol6q2pU6WVrktOHufcZ6ecLkWcNarvRYH96SjBpTI1h72Qi00pCZWo88
MrPF1qbMEqNP3HDXZOKYQNIxeVaJws6fMdhuSuZ6+ZaBUV83ZLbWIyMC1U4yJEMw6E4Vcwcy
mPLFBBZuJvI9tMydaVa522VQET5fSZbVrjkTma31pq1vTMBFvNc3mXUvhhFZgXV/5fXyfXKj
v8vFtWRLE/x8ZrHEOItKkjEzVTatKd6w4GNP0u6CuwNZg6He8S1GouPNG5OsPazleMd4UBsJ
6iex3lcMAv5mbOiAz7lelrZt/Ka7Ckm9SKHbTKxtqWdj2sJryYo5N9nfJm+ynWQU/7PY96lg
O/aZOSfZlO9yBMvZV+acq/kwdSm9D/MZPzOxl39csK73f8zoq5l+Y5n0XR6eu73P9RdaXhR+
E/jhGAAAAABJRU5ErkJggg==
--------------010303010001040508070206--
The message was, according to jemh, processed, nothing pops up in jiras log and a comment "mail text here" is added. But no attachment is added to the issue. Same goes for creating an issue via mail.
What am I missing?
Greetings,
Christian
BTW: is it really normal behaviour, that blitz-action-screen-conditions are invoked when jemh posts a comment?

1 answer

This widget could not be displayed.

I get all the mail! no need for post duplication on other forums! This is now being tracked @ https://thepluginpeople.atlassian.net/browse/JEMH-2264

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Aug 06, 2018 in Jira Service Desk

A is for Activate: Share your top Jira Service Desk onboarding tips for new users!

Hi, everyone! Molly here from the Jira Service Desk Product Marketing Team :).  In the spirit of this month's  august-challenge, we're sourcing stories of Jira Service Desk activation fro...

578 views 25 15
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you