javax.servlet.jsp is not exported in the SystemBundle

Hello!

I'm running jira on Tomcat 7 (actually SAP neo-java-web 2.6.0) and after a restart the SystemBundle no longer exports "javax.servlet.jsp" which causes "Atlassian Embedded Crowd - Administration Plugin" to fail to load.

Here is the jira log:

2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#___ FAILED PLUGIN REPORT _____________________|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#2 plugins failed to load during JIRA startup.|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#	'com.atlassian.support.stp' - 'Support Tools Plugin'  failed to load.|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#		Cannot start plugin: com.atlassian.support.stp|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#			Unresolved constraint in bundle com.atlassian.support.stp [122]: Unable to resolve 122.0: missing requirement [122.0] package; (package=javax.servlet.jsp)|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#		It was loaded from /usr/sap/ljs/data/plugins/.bundled-plugins/stp-3.5.2.jar|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#	'com.atlassian.crowd.embedded.admin' - 'Atlassian Embedded Crowd - Administration Plugin'  failed to load.|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#		Cannot start plugin: com.atlassian.crowd.embedded.admin|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#			Unresolved constraint in bundle com.atlassian.crowd.embedded-crowd-admin-plugin [32]: Unable to resolve 32.0: missing requirement [32.0] package; (&(package=javax.servlet.jsp)(version>=2.3.0))|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#		It was loaded from /usr/sap/ljs/data/plugins/.bundled-plugins/embedded-crowd-admin-plugin-1.7-m6.jar|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#1 plugin are unaccounted for.|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#Unaccounted for plugins load as artifacts but fail to resolve into full plugins.|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#	'com.atlassian.labs.jira.emaileditor.emaileditor-jira-plugin' - 'JIRA Outgoing Email Template Editor'  is unaccounted for.|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#		It was loaded from /usr/sap/ljs/data/plugins/installed-plugins/plugin_360220645704924568_emaileditor-jira-plugin-1.3.1.jar|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-7#|
2014 08 27 09:09:33#INFO#LJS_OUTPUT#Thread-

Any idea what might be causing this ? I removed the ".bundled-plugins" and ".osgi-plugins" folders but it didn't help.

Best regards,

Svetlin

1 answer

During a migration of JIRA I ran into the same error. The problem in my case was due to a wrong pointing to the tomcat6 WAR distribution even if the runtime was on tomcat7.

Changing the pointer on jira.xml to the right WAR the is gone.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Sunday in Agility

You asked for it, so we delivered: images on issues have arrived

A picture tells a thousand words. And agility boards have just released their latest feature: cover images on issues – so now your board can tell a story at first glance. Upload attachmen...

218 views 2 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you