Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

iqlFunction in Jira Insight not working for Customfield type "Insight Referenced Object"

Hi

I am trying to utilize the iqlFunction("") in a JQL Query, when setting different SLAs as a specific attribute in a Insight Object Type defines what SLAs it is supposed to use.

I found the documentation how to utilize IQL in an JQL Query, with partial success. 
https://documentation.riada.se/display/ICV49/Insight+JQL+Functions

The problem that i have is that the Custom Field created utilizes the Custom field type "Insight Referenced Object (Single)" and i can not get the "iqlFunction("")" to work with that specific type. If i try with Another customfield with the type "Insight Object/s" i do get full functionality.

Is this a bug or am i missing something with utilizing the customfield type "Insight Referenced Object (Single)"? 

Will the function "iqlFunction" not be usable when developing an own customfield utilizing the Insight objects?

Best regards
Pontus 

1 answer

Hi @Pontus Ridderström,

Check this question which is similar to you in the link below.

https://community.atlassian.com/t5/Answers-Developer-Questions/Getting-complete-list-of-all-fields-using-JIRA-REST-Java-Client/qaq-p/509008

This will give you a list of "fields" from the JIRA Server which you can use.

Hope this helps!

Thanks for your response @Kirubel Tesfaye
I am uncertain however how this actually answers my question. 

As i do not request to know the avaliable fields in the Jira Instance but rather want to know if the JQL function "iqlFunction("")" supports the Custom Field type ""Insight Referenced Object".

Best regards

Like # people like this

I also had this problem and eventually solved it.

Looks like the function doesn't work with translated fields as it searches somehow by translation (?).

As soon as I aligned the original field name with the current user language translation it worked.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you