invalid character 0x1b in Jira export entities.xml

Hi,

 

I would like to migrate my JIRA installation from JIRA Server Software (7.1.9) to JIRA Cloud. I have created the XML export file as jira.zip and the data folder as jira-data.zip. I uploaded both to the WebDAV folder.

 

When I try to start the import I get the following error:

"There was an error parsing the entities.xml file: An invalid XML character (Unicode: 0x1b) was found in the CDATA section."

Anyone know anything about that? There are a few very old bug reports with similar error messages, but they seem to have been fixed a while ago. I found no other information about this.

1 answer

you have to remove 0x1b with the following:

 perl -i -pe 's/\x1b//g' entities.xml

 

It worked afterwards.

 

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Apr 17, 2018 in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

800 views 2 19
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you