It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage
  • Community
  • Products
  • Jira
  • Questions
  • followed all steps but even then all users can all project. Can you please make sure that this article is still valid for v7.1.2

followed all steps but even then all users can all project. Can you please make sure that this article is still valid for v7.1.2

This question is in reference to Atlassian Documentation: Limit/Restrict User's Project Access

followed all steps but even then all users can all project. Can you please make sure that this article is still valid for v7.1.2

1 answer

0 votes

Have you removed the standard groups from the roles?  The defaults are to put jira-users into every project "users" role, which allows them in.  As jira-users is also the group of "can log in", it grants access to everyone. 

To confirm this with our help, could you show us what you have for "browse project" in your default permission scheme, and then show us the users and groups in the roles for a project?  (feel free to obscure user names, it's only the groups we care about here really)

Hi Nic,

Thank you very much for your quick reply.

I have the following roles:

1.jpg

I added Quality Assurance and Software Engineer roles and there is no default member in these.

 

Here are my project groups (each project have dev and qa group):

image2016-4-25 17:3:41.png

I wan to configure each QA and Dev group against the following projects:

image2016-4-25 17:4:42.png

For the time being, I am using Default software scheme for all projects:

image2016-4-25 17:5:58.png
Here is my users and roles for SigningHub Desktop Web app:

image2016-4-25 17:7:4.png

Can you please tell me what I am doing wrong that my projects are shared with all groups?

Also, do I have to create multiple permission schemes for all projects or can I work with one permission scheme?

Could you show us the permission scheme you're using.  I asked specifically for the "browse" line in it.

image2016-4-25 17:40:2.png

I am sorry for that, here is the request information.

That's answered it - you've got "any logged in user" in the permissions.  Change that to a role of "user" instead.

I have exactly same issue, all my Roles and Groups are configured and has Browse Projects set to "Any logged user". Cannot see the option role of "user" in Edit options. Could be more specific. Thanks

That suggests you've removed the role of user from your system, so you may have to use a different one.  What do you see when you click edit?

Did not remove any role, I'm a new user so I have everything as configured by default, anyway I resolved my issue following this tutorial https://www.youtube.com/watch?v=wvdVNpgG34M

Thanks for your reply!

Ah, so you followed the instructions above , as they're the same as the tutorial.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you