customfield datetimepicker problem with summertime

Hi.

 

We have a custom field as date time picker and an own written mailhandler.
The mailhandler looks for this custom field like this:
issueInputParameters.addCustomFieldValue(id, "31/Mar/15 8:13");

 

Since it changed to summer time, it writes now in this customfield "31/Mar/15 9:13" (+ 1 hour).  Are there some settings to fix this or do I have to program a workaround in the mailhandler?

 

Thank you in advance.

 

2 answers

Hi!

Maybe there is a problems with timezone. Look at this https://answers.atlassian.com/questions/9880988

Thank you for the hint with the timezone.

The problem was the timezone from the user which creates the issue. There it was set to an African timezone. After changing it to Europe Berlin, it works fine.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Sunday in Agility

You asked for it, so we delivered: images on issues have arrived

A picture tells a thousand words. And agility boards have just released their latest feature: cover images on issues – so now your board can tell a story at first glance. Upload attachmen...

171 views 1 10
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you