custom field change doesnt appear in issue history

Hi,

we've just migrated to jira 5.1.4 and noticed, that a change of a custom field value on an issue is not stored in the issue history.

I would be grateful for any ideas of what the problem coud be

thanks

Rad

7 answers

1 accepted

This widget could not be displayed.
  1. Backup your JFS settings
  2. uninstall JFS
  3. Shut down JIRA.
  4. Delete contents of the <tt>JIRA Home Directory\caches\indexes\changes</tt> directory
  5. Delete contents of the <tt>JIRA Home Directory\caches\indexes\comments</tt> directory
  6. Delete contents of the <tt>JIRA Home Directory\caches\indexes\entities</tt> directory
  7. Delete contents of the <tt>JIRA Home Directory\caches\indexes\issues</tt> directory
  8. Remove the content of the following directory:
    • <JIRA Home Directory>/plugins/.bundled-plugins
    • <JIRA Home Directory>/plugins/.osgi-plugins
  9. Restart again.
  10. Perform re-indexing
  11. Install JFS again
  12. import your JFS settings

It worked on our side (don't ask me why)

Udo

Thanks Udo, your suggestion + suggestion from Atlassian support (points 3 to 10 from your list + deleting directory Catalina located under <tt>$JIRA_INSTALLATION\work)</tt>worked!

I appreciated your help,

Regards,

Rad

I have used the same workaround with success - however it seems that if I stop/start my JIRA instance I get the same problem and have to go through the full cycle above to make all correct - Is there still a JFS root cause issue that needs to be addressed?

Hi Anthony, If I member it correct we didn't had the the JFS plugin installed correctly with the patches provided by quisapps. After we did that we had no further issues.

Can you provide your JFS version and applicable patch versions? - Thanks

Sorry I can't (not with the customer anymore). Please see here: http://www.quisapps.com/confluence/pages/viewpage.action?pageId=3047432

This widget could not be displayed.

Have you any third party Plugins installed?

This widget could not be displayed.

We have the same issue. Atlassian think it might be due to a third party plugin (in our cases the JFS Plugin). We were not able to confirm it yet...

This widget could not be displayed.

yes, we use third party plugins

This widget could not be displayed.

we use JFS plugin too...

This widget could not be displayed.

Can you elaborate, how is the change being done? Is it done using a standard JIRA workflow action or Edit or is it done by the plugin?

This widget could not be displayed.

i tried to change the custom field value by editing the issue and using postfunction "Update issue custom field" but i cant see the change being recorded in the issue history

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

122 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you