[closed] Scripted Validator: Add Parameters To Validator... Add button not working!

I'm using the groovy plugin to define a 'Scripted Validator' rule behind a transition but the 'Add' button in the ' Add Parameters To Validator' page does NOT submit the page.

Any ideas?

Thanks

10 answers

1 accepted

This widget could not be displayed.

The 'Add button' problem seems to be one of the issues related to Groovy Runner v2.0.7 installed in JIRA v4.x. I had tried also the latest version of the plug-in which did not work too because it is JIRA 4.x compatible. With my current JIRA set-up I did not find any way to use the Groovy Plug-in unfortunately.

Looking forward to move towards JIRA v5 and the latest version of the plug-in.

Ps. Jamie, Wolfgang, many thanks :)

This widget could not be displayed.

I believe it doesn't work with IE, should work with everything else. Not tested opera. This is a known issue.

Jamie is right - it looks like it does not work with current IE versions (9 and 10) any more.

I thought it has worked with older versions, but not sure any more.

At least it works with Firefox.

This widget could not be displayed.

Which browser do you use?

I have the same problem using Opera, but it works with Firefox and InternetExplorer.

This widget could not be displayed.

Sorry for not mentioning it before. I've tried it in Firefox, Chrome and IE with no positive result. It seems like the button being disabled (althought is clickable).

Is there any alternatives to groovy validators?

This widget could not be displayed.

Also can you check the jira log for errors.

This widget could not be displayed.

Weird. What's your jira version and plugin version?

This widget could not be displayed.

Here we are: Jira 4.3, groovy runner 2.0.7

Firefox 16.0.2, Chrome 22.0, IE8

I've noticed that there is the new version 2.0.11 of the groovy runner which says "Fixes an issue where you can't add new workflow functions". I'm going to update the plug-in first...

This widget could not be displayed.

Yeah, it was a different problem than I thought. But I think that version is only for jira 5.1+.

This widget could not be displayed.

Yes, the plug-in v2.0.11 seems to be only for Jira 5.x . When I tried to use the plug-in on Jira 4.3, it caused blocking errors (no issues o projects displayed more).

This widget could not be displayed.

2.0.7 was never available for 4.3... choose the right version for your jira from https://marketplace.atlassian.com/plugins/com.onresolve.jira.groovy.groovyrunner.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

277 views 1 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you