Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

can´t disable xsrf token

i try to use this link to create an issue

http://xxxxxxxxxx:8080/secure/CreateIssueDetails.jspa?pid=10000&issuetype=9&summary=BLA&myParameter=true

but i receive this followin error

---------------

XSRF Security Token Missing

-------------------

i tried to disable the the XSRF token option

follow the instructions of the next page

https://developer.atlassian.com/display/JIRADEV/Form+Token+Handling

using this property and value in the jira-application.properties file

jira.xsrf.enabled=false

but it doesn't work

i tried to find jira-config.properties file in the JIRA-HOME directory but the file it's not there

please help

i need this for a demo

i can't use the Advanced Config interface because i don't have JIRA-System-Administrator permission

i don't know why this permission isn't on the global-permission section

3 answers

1 vote

Indeed you'll need to change this option in the <tt>jira-config.properties</tt> file rather than in the <tt>jira-application.properties </tt>if you are running a more recent release of JIRA. Also, in new JIRA installations, this file may not initially exist and if so, needs to be created manually - Just add the 'jira.xsrf.enabled=false' option to the file and restart JIRA so the changes will take effect. :)

I am on Jira 6, this tip unfortunately did not work for me. Any idea?

You may have run into https://jira.atlassian.com/browse/JRA-34749- you can vote or comment there. Alternatively you can use the "X-Atlassian-Token: nocheck" header if you're using a script.

So I encountered this issue today when trying to clear the default value for Resolution field. The fix I have found for this is to go to the WEB-INF/classes directory and modify the value below from true to false in the jpm.xml file . You will have to restart jira for change to take effect.xsrf.jpg

@Lou-Guardia Can you confirm which Jira version did you observe this?

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you