Workflow transition screen is not loading

I have a workflow transition in which I am associating the Edit screen of the project. While selecting the workflow the spinning image is shown but screen is never loading to proceed with the workflow. There is not error in the logs and I have no starting point to investigate this. 

Does anyone have an idea how to proceed with such a case?

7 answers

This widget could not be displayed.

Jira 7.10.2 (server)
Users cannot edit, assign or progress items when viewed from the dashboard filter e.g. 

/jira/browse/JIRA-98?filter=-1 (look in your url bar of the browser)


Workaround: RMB (right-mouse-button click) to open the item in a new tab e.g. /jira/browse/JIRA-98. Works fine then (or remove everything in the url from ?filter= )

Looking forward to a fix for this bug.

This solved the problem on Jira running on a Windows-Server with IIS: JIRA elements fail to render with HTTP 400 error

This widget could not be displayed.

Check the logs for error, check the browser console for errors. Try a different browser.

This widget could not be displayed.

Thanks Gabrielle for your comment but exactly this is my issue. I try with Chrome and IE and for both browsers I do not have anything in the tomcat/jira logs neither in the console of the browser. Somehow I believe the problem is with the Edit Screen. The same screen is loaded correctly with Edit command but is never loading during the execution of the workflow (which is using the same screen as transition screen).

This widget could not be displayed.

Try using firefox, and install firebug. There will be a hint in there if there's really nothing in the logs

This widget could not be displayed.

Same is happening with firefox and firebug. The last execution is the following url

 

https://jira/secure/WorkflowUIDispatcher.jspa?id=<id>&action=<actionId>&atl_token=<token>&decorator=dialog&inline=true&_=<numbers>
This is returning 302 Found status in which is redirecting to

https://jira/secure/CommentAssignIssue!default.jspa?inline=true&action=<actionId&atl_token=<token>&_=<numbers>&id=<id>&decorator=dialog

At this point no activity on the page - only the spinning image - no error on console.

If I enter the first url in a new browser tab then redirection is done and the edit screen is shown (not correctly as it does not exists in the modal container)

 

Also still not a single log/error in any available log file!

This widget could not be displayed.

I just figure out that the popup containing the edit form is available in the page dom but is hidden. So the problem is to hide spinning image ena make form visible.

Nice! Sounds like its a temporary fix though? Better find out what's the cause.

This widget could not be displayed.

I am having the exact same issue at work.  If set the screen to "None" in workflow, it will transition fine.  My initial thought was that I had some incompatibility with a 3rd party addon like JSU or JMWE, and so I downloaded the latest versions of those addons.  Same result.  If I specify to load the "Edit/View" screen in a transition, then I get the spinning wheel-o-death.  I truly feel this is a bug.....a major bug.  I am still trying to go through my error log to see if I can find anything but right now nothing to go on.  If I figure it out I will come back and provide an update.

It probably is a bug, but as the transition screens are drawn up by the same code as create and edit, it suggests that you have a broken field on the transition screen (from an add-on), or an add-on doing bad things with the fields.  My first instinct is to wait for a quiet time and temporarily disable all the user-added add-ons and see if it works without them.

But if it's not that, Is this only for this one screen?  If you have other screens that are ok, what is the difference?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted 5 hours ago in Jira

Atlassian Research Workshop opportunity on Sep. 28th in Austin, TX

We're looking for participants for a workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sha...

23 views 1 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you