Workflow problems

Hi -

I have a ticket that was created and is in the "New" stage, but the options to move it through the workflow are not showing up. This has only happened with about 5 tickets in the last 24 hours. If I create a test ticket, the workflow options show up just fine. If I take the ticket that doesn't show the options and Clone it, the Cloned copy shows the options to move through the workflow.

Really strange. Any ideas?

1 answer

1 accepted

1 vote
Accepted answer

You must have some workflow conditions which is blocking you from progressing it.

An example would be a condition like "Only Assignee can execute this transition"

Can you try the integrity checker and see if there are any workflow steps/states that needs to be fixed?

https://confluence.atlassian.com/display/JIRA/Using+the+Database+Integrity+Checker

The conditions used are:

Only users in project role Administrators can execute this transition.
— OR
Only users in group jira-administrators can execute this transition.
— OR
Only users in group Technical Director can execute this transition.
I'm a jira-administrator. I don't see the workflow options. I do see the workflow options if I clone the ticket.

Trying to run the integrity checker, but it keeps erroring out. It's really odd though that the direct clone of the ticket works correctly.

Integrity checker keeps throwing a proxy error every time I try to run it.

Clone is essentially doing a new create. What could be the difference from the original create? My guess is that you might have some custom code that is fired during create. Of maybe the indexes are going crazy. Any error in the logs?

Must be some DB transaction error during that time I guess. You can fix it only using the integrity checker (or in the DB).

Not that I can find. Shouldn't be any custom code during create. I have also tried creating these as new tickets. All the same information, fields filled out exactly the same, etc. Essentially doing a manual clone, but through the new ticket process and they work fine. It is solely these 5 tickets, created during a 2 hour window it looks like.

To update, I found a work around to the problem. I actually made a copy of the workflow (completely identical) and applied it essentially as a new workflow for the ticket type. All the same ticket statuses, so the tickets were unaffected, other than it solved the problems and the few that I couldn't move through the workflow now move correctly. Strange. We'll see if it ever happens again. Thanks for your help!

By the way, I also tried re-indexing the database before implementing this "fix" which did not help.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,721 views 17 21
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you