Workflow button disappeared from few issues in one project only

Hello,

I have come across this issue for the first time where few issues in one project are missing the Workflow button and I cant even drag them from one staus to another. we are in 6.4.12 version. 

I tried to change the issue type and bring it back to original issue type. That didnt help and after researching I found that republishing of workflow helps. but havent tried that. and someone could let me know how I can do that without interuppiting other projects that share the same workflow will be a great help.

Thanks

4 answers

1 accepted

Accepted Answer
0 votes
Gaston Valente Community Champion Sep 03, 2017

Leena, did you try running the integrity checker to detect and solve workflow issues?

Yes and that fixed the issue.

 

Thanks a lot.

Gaston Valente Community Champion Sep 06, 2017

Great!

Thomas Schlegel Community Champion Sep 07, 2017

@Leena Bakshi: I'm curious ;-)

What was the problem? It might also help other people reading this. 

Integrity checker showed errors in the workflow entry state. for issues in two different projects instead of one.Integrity checker result.JPG

 

Please see the screenshot. so all I did was clicked on Fix and it did FIX !! :) 

0 votes

Hi Leena,

most of the time, the reason why a workflow transition is not available (and therefore the button not visible) lies in the workflow itself.

If you encounter this the next time, please check the conditions of the workflow transition:

Is there a condition that hides it from the user? Might be that there are open subtasks or that the user is not allowed to trigger that transition.

0 votes

Leena,

As Thomas said, the most common reason is a validation in the workflow.

If you have another issue with equal values in the fields and same status and you can do the transition, maybe you can run the integrity checker to find and solve problems in that particular issue.

Thank you for the prompt reply Thomas and Gaston. However I did check the workflow and in the condition for the transition from open to another status it says user with edit permission can move the issue however another user who is the project lead also couldn't drag the issue and me being system admin in Jira also couldn't do it. And they just raised one more issue having the same problem that workflow button being missing. 

I am going to re index this weekend will check if that fixes the issue. 

 

Thanks

Re indexing didnt solve the issue. Any more ideas??

I tried to clone the issue and that seem to fix it ..but I know its not a permanent solution. 

None of the following helped

Reindexing

changing the Issue type

Conditions were all good.

 

What helped: a workaround

Cloning of the issue

Thomas Schlegel Community Champion Sep 04, 2017

Hi Leena, 

could you please upload screenshots of your workflow transition with all the conditions and also please the permission scheme of your project?

It's not easy to find the problem without further information.

Thank you

Thomas

Hi Thomas,

Thank you for your help in this matter. I really appreaciate it. 

Please find the screen shots attached of the permission scheme and workflow and their conditions and post function.

We have the same condition amd post function for all the transitions in this workflow.

 

workflow1.JPGPermission1.JPGpermission2.JPGpostfunction1.JPGpostfunction2.JPG

leela,

try running this query.

UPDATE os_wfentry SET state = 1 WHERE state = 0;

Gagan, the issue was resolved after running the integrity checker and fixing it from the suggetsion resolution.. However Thanks, can lookinto it if needed again.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 25, 2018 in Jira

Atlassian Research Workshop opportunity on Sep. 28th in Austin, TX

We're looking for participants for a workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sha...

439 views 7 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you