Wiki Style Renderer - Image thumbnail not working

Hi Guys,

I'm having an issue with images which I have attached to issues, they do not display when using the exclamation mark wiki markup notationin. I have enabled wiki style rendering and double checked everything on the atlassian doco pages.

I can link to the attachment using this form of the wiki markup:

[^imagename.png]

Although when I try and reference the attached image file with either of these notations I get nothing, it doesn't even change text colour to red:

!imagename.jpg|thumbnail!

!imagename.jpg!

Here is an image of what I see, the same happens for description fields with the renderer set. As you can see the square brackets notation is linking to the attachments corrrectly although the image links are not.

I don't receive any errors in the server log. I am using Jira "6.0.8", tried on both Java 1.7 and 1.6. OS Windows Server 2k8 r2.

Any help with this will be much appreciated.

Thanks,

Jesse.

9 answers

This widget could not be displayed.

Still the same. We updated to *v6.3.12#6343*. thumbnail won't appear. But with a '* ' or '# ' (list) in front of it, it works.

Global settings '*Enable Thumbnails*' is on:

Miniaturbilder aktivieren
Ermöglicht die Erstellung von Miniaturbildern von Bildanhängen.
EIN

Used browsers:

  • mozilla firefox 34.0.5
  • ie 11.0.9600.17728
This widget could not be displayed.

Did you got any update on this? We also have this Problem on a JIRA 6.1.5 running on Ubuntu Java 1.7

This widget could not be displayed.

We have the same problem (JIRA 6.1.5 running on Ubuntu Java 1.7) but I found a *workaround*: Put first a numbering, that means the number sign *#*. After that your !myjpg.jpg|thumbnail! - expression. The attachment (picture) must have name like '*.jpg', that means it is case sensitive. Attachments like '*JPG' doesn't work, although you write *!myjpg.jpg|thumbnail!* or !myjpg.JPG|thumbnail!*

This widget could not be displayed.

Thank you Siemon for your workaround. We are expecting the same issue under JIRA 5.0.6. @Atlassian: is there already a ticket filed for this issue? If so, can you please provide the link. Thanks.

This widget could not be displayed.

Hey guys, I have created an issue for that bug. Please see https://jira.atlassian.com/browse/JRA-40828

This widget could not be displayed.

Same issue in JIRA 6.1.7

Do anybody knows - fix it or not in latest versions?

This widget could not be displayed.

There is the workaround, that's it. Atlassian wrote, that they didn't find any bug, feature ist working fine and if there are problems, they are due to individual surroundings.

So, there will be no fixing sad

This widget could not be displayed.

Have you verified if the  'Enable Thumbnails' field has been set 'ON' in Administration >> Global Settings >> Attachments.

It might be the case!

It's been a long time since anyone last made a comment here, but it might be good for future references!

Thanks!

This widget could not be displayed.

Quite old thread but Google brought me here instead of https://confluence.atlassian.com/jirakb/image-attachments-are-not-displayed-inline-in-wiki-renderer-fields-723518199.html

"Internet Explorer MIME Sniffing Security Hole Workaround Policy"  "Secure: forced download of attachments for all browsers" may cause these issues.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

135 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you