Wiki Page Failed to load

Hi folks,

Using Jira v5.2.7 and confluence v5.1.3, configured as trusted applications. In some issues mentioned from the wiki Im getting "Failed to load" error. Remote API is enabled in jira and confluence, and most links are working, but in some links the above error is shown and I have no idea on how to know its cause.

The link anchored in "Wiki Page" is correct and pointing to the right confluence page, but is unable to get the wiki page title from jira (?)

Some related questions:

https://answers.atlassian.com/questions/39560/can-t-link-confluence-page-to-jira-issue-using-application-link-and-oauth

https://answers.atlassian.com/questions/82618/what-causes-jira-to-issue-the-message-wiki-page-failed-to-load

4 answers

1 accepted

0 votes
Accepted answer
Peter Koczan Atlassian Team Jun 16, 2013

Hi Alex,

We may need to look more into your logs to determine what the error could be in this case. Would you mind opening a support ticket at http://support.atlassian.com attaching a support.zip from both Confluence and JIRA so that we can look for possible causes?

As a hint, JIRA and Confluence versions need to be checked, maybe the applinks plugin is not compatible with one of the versions being used.

Kind regards,

Peter

Where can I check if these versions are compatible? We didn't checked at all before migration.

Supposing that the appslink plugin contained in jira and confluence are different/incompatible versions, can we upgrade it from one application to make it compatible?

Im going to open that support ticket as you recommended ...

created support case: JSP-166344

1 vote
Peter Koczan Atlassian Team Jun 16, 2013

Hi,

Did you check your logs on both Confluence (<CONFLUENCE-HOME>/logs/atlassian-confluence.log) and JIRA (<JIRA-HOME>/log/atlassian-jira.log) when loading the page/issue to see if you can find any additional pointers on the nature of the error?

I also suggest running Hercules log scanner on your logfiles at Administration > Atlassian Support Tools > Log Scanner, maybe you will see an obvious error with a solution on the spot.

Kind regards,

Peter

In jira logs:

Runtime Exception when accesing to REST API ("Failed to parse Confluence Remote Api response").

Caused by: SAXParseException, The element type "br" must be terminated by the matching end-tag "</br>"

...?

Am i missing something?

0 votes
Henning Tietgens Community Champion Jun 16, 2013

I think my question is similar, too: https://answers.atlassian.com/questions/125628/remote-issue-link-between-jira-and-confluence-shows-failed-to-load-in-jira

There I have a NPE within the log, but that error doesn't help me.

0 votes
Peter Koczan Atlassian Team Jun 16, 2013

Hi Alex,

https://confluence.atlassian.com/display/APPLINKS/Application+Links+Version+Matrix

Here you can find the information.

Cheers,

Peter

There is no mention to confluence 5.1.x in that table ... I'm going to gather logs and I'll open a support ticket

Thanks.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,403 views 15 19
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you