Why would 'source' tab be missing in my new instance of JIRA?

Greetings,

In our new JIRA, I can't see the 'Source' tab on a JIRA issue but in our older version of JIRA I can see it just fine. All I see under 'Activity' on the JIRA issue is: All - Comments - Work Log - History - Activity (but no Source).

At first I was thinking that maybe code had to be tied between our SVN and JIRA as our older JIRA and SVN are integrated, but when I opened a JIRA issue in our older JIRA it shows 'Source' even though there's no code commit for that issue.

Thanks in advance for your help.

B/R,

Melissa

3 answers

1 accepted

Accepted Answer
0 votes

Source tab is driven by the "View Source Control" project permission. Do you have that permission in the new JIRA?

Hi Jobin,

I'll have to check. I thought it would appear as part of the default in JIRA? Where should I look exactly?

Thanks for your help, Jobin.

Melissa

Project permissions : https://confluence.atlassian.com/display/JIRA/Managing+Project+Permissions

You should also have the integration with SVN setup - hope you aleady have it.

Update: I went to permissions and added Developer Project Role and Anyone (for good measure) but still not seeing source tab. Any suggestions about how to further troubleshoot?

That's why the tab is missing. It will appear only if the plugin is installed and configured.

Are you using the subversion plugin or Fisheye?

Thanks very much Jobin.

Is this SVN Plug-in something we have to purchase? Someone else ordered all our Atlassian products before I was here and I don't remember seeing anything about an SVN Plug-in mentioned on my project.

We don't have Fisheye installed and all we have is the pre-commit hook in place. We're not using the new JIRA or the new SVN yet.

Hi, I went to this URL to see about downloading the JIRA SVN PLug-In and it looks like it's free but it also looks like there's some issue (see thread).

https://marketplace.atlassian.com/plugins/com.atlassian.jira.plugin.ext.subversion#versions

Extract I found from a user that's with today's date:

Forced to rate but Im unable to download so ignore the rating... Where is the download for the latest version - all I can see are release notes for the latest version. Why CVS is installed by default and Subversion is not is very surprising. Why Atlassian's own Greenhopper plugin cant be installed through their own plugin manager is also surprising.

Vendor Response

Hi Nick - there was a Marketplace server problem that caused download links not to appear on a number of plugins, not just this one; this should now be fixed. Not sure what you mean about Greenhopper not being installable, but I'd suggest following Greenhopper's support link and raising an issue there.

Jobin, I found out that Fisheye was installed (just not integrated yet with our new JIRA) so once that's done then the source tab will appear?

Yes, once Fisheye is integrated, source tab will appear.

Hi Jobin, sorry I couldn't check back sooner but that's exactly the guidance I needed. Thank you very muchl.

Do you have the relevent applications link and project links created?

I have the FishEye application link applied but will need to double-check the project link as I don't recall about this being a step that needed to be done when I looked at the instructions in the JIRA manual?

If the application link is correctly configured and if you have permission, it should appear. See https://confluence.atlassian.com/display/FISHKB/Source+tab+does+not+appear+on+View+Issue+or+Browse+Project+page+in+JIRA

Make sure there are no errors!

Project link and app link were applied but still not sure what I'm missing. (Thanks for that link you sent above as I'll use that for a basis upon which to continue to troubleshoot).

Hi Jobin, I wanted to follow up and tell you that I have FishEye integrated with JIRA now but still can't see the 'source' tab. I could see the Source tab in our older JIRA even when no code was associated with an issue but not with this new instance of JIRA. So what could be causing that problem?

Thanks in advance for your help.

Melissa

Finally can see the Source tab (as of 5 minutes ago)! The fix: Enable JIRA's remote API and to also enable Fisheye's remote API. You can not believe the hours that went in to troublehsooting this. I was about to lose my mind (what was eft of it!). Thanks for the assistance along the way. Much appreciated.

Good to know :) That is the first step in the integration and obviously the one which we tend to ignore!

You would have seen some error in the logs for this though!

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 25, 2018 in Jira

Atlassian Research Workshop opportunity on Sep. 28th in Austin, TX

We're looking for participants for a workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sha...

416 views 7 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you