Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,362,591
Community Members
 
Community Events
168
Community Groups

Why some issues are crossed out?

I have some issues that, even with resolution = "unresolved", they are crossed out. 

I´d like to cross out just when the issue is with another status.

image.png

image.png

 

 

 

 

 

 

 

4 answers

1 accepted

1 vote
Answer accepted

It looks to me like one of your inexperienced adminstrators has added "unresolved" to the list of resolutions.

Go to Admin -> Issues -> Resolutions and look at the list.  If it has "unresolved" on it (or any other phrase that means "not closed"), edit it and change it to "Broken Resolution option - do NOT select this".

Then check your struck-out, but unresolved issues again.

Hi, how are you doing?

@Nic Brough (Adaptavist),

I'm looking for your solution, and it's been placed unresolved, since the value of the field once changed to any other, does not allow you to return to unresolved, since it is not presented in the field and needs this value in specific.
For that reason it was included, I followed the process that mentioned, and changed the name of the value, but the occurrences did not undergo changes.
Same

I'm sorry, I do not understand that.  (It's been a long day, I'm struggling)

When you go to Admin -> Issues -> Resolutions, is there "unresolved" on the list anywhere?

@Nic Brough _Adaptavist_ Just what I created, because natively does not exist.
An occurrence starts with the value "unresolved", if with the progress of the flow you change the resolution to any of the others and try again to return to "unresolved" it does not appear in the list of the combo.
So I went directly to Admin -> Issues -> Resolutions, but this value also does not exist in the list of resolutions, so I created an "unresolved" resolution to meet user demand, which needs to be able to switch from any resolution to "unresolved" .

Thanks, that has cleared it up perfectly.  You say

> so I created an "unresolved" resolution

That is the problem.  You should never do that.

Now what you need to do is:

  • Rename "unresolved" to "do not use" or something equally off-putting
  • Look at where you have put it on screens.  You must never have it on
    • Create
    • Edit
    • Transition screens that are not going to a "closed" status

That will stop the damage spreading.

Now you will probably want to fix the broken ones that now have "do not use" on them.  You need to do one of:

  • Push them through transitions with a post-function that clears them
  • Use a ScriptRunner built-in script to repair them
  • Add temporary loops with "clear resolution" post-functions to your workflow(s) and use them on the broken issues
Like # people like this

Thank you Nic! I´m going to try it.

1 vote
josh Rising Star Jul 26, 2018

This is strange indeed. Have you tried to run the integrity checker in the administration-->system page? Also try reindexing, if you haven't tried that already.

Thank you, Josh. Tjhe reindex is being done daily.

If this occurrence had started as "Unresolved", and at one time I had edited "Fixed" and again for "Unresolved" before the transaction that would make this exchange, could this possibly cause the problem?

the passed integrity checker did not return any errors, "indexing" was also passed without any errors, our log does not contain an error linked to this project and in its database.

The version of the jira presented is version 6.4.”

Totally agree

0 votes

HI @Ana Lucia Onishi

Welcome to the community!

Please make sure the Resolution field should not available on any Create/Edit screen or transition. It should only available on the transition screen where the user will closed/resolved the issue. 

josh Rising Star Jul 26, 2018

As you can see, the specific issue BRA1-35 is unresolved, yet the backlog is showing the issue with strikethrough as if it were resolved, there has to be either a database or indexing problem here.

Joe Pitt Community Leader Jul 26, 2018

I see it is BLACK not RED like it is normally when the field is null. Did someone add 'Unresolved' to the resolution list thinking that makes the issue unresolved in JIRA? I've seen that before. 

josh Rising Star Jul 26, 2018

@Joe Pitt Unresolved doesn't show up as red on my Jira. Maybe it does on a later version of Jira or on cloud? But yes that's a good thing to check.

The version of the jira presented is version 6.4.

Thank you!

Suggest an answer

Log in or Sign up to answer