Why is Epic Link field not save during Create Issue, unless User Group as Edit Issue Permission?

Why is Epic Link field not save during Create Issue, unless User Group as Edit Issue Permission?

I want to limit users from Editing existing issues, unless they are the Reporter of the issue. I have the Epic Link field defined as one of the attributes of the issue that can be set at Issue Creation time. I have given Create Issue permission to the Group g1, and Edit issue permission to the Reporter. I have a set of users that are in Group g1. If g1 is NOT given "Edit Issues" permission, the Epic Link field can be filled in by the Reporter (who is a member of g1) on the Create Issue Screen, but when completing the screen, and creating the issue, the Epic Link field does not show up. Similarily the field does not show up after using the Edit Issue screen.

What can I do differently such that I do not have to give Edit Issue permission to everyone in Group, in order to be able to allow the Reporter, a memer of the Group, to set the Epic Link during Issue Create?

11 answers

Hi Rick,

I've come across this while trying to solve a related problem. It seems that the Epics which show up in the "Epic Link" field when editing are any Epics the user can "see", i.e. Epics in any project where the user has the "Browse Projects" permission. I think that in order to be able to link two issues (in this case, link something to an epic) you should need the "Link Issues" permission for both issues (i.e. if they're in different projects you will need permissions in both projects). Maybe you also need the "Edit Issues" permission as you seem to have found.

So, basically the problem is that you can select an Epic on a screen which you don't have permission to link to. I have found that if I do this, the issue creation succeeds but the Epic Link field is blank. There is no error message or warning, it just doesn't link to the Epic. I think this is what is happening for you. That doesn't help with how you can grant permissions to just the reporter, but hopefully explains why you're able to pick the Epic on the create screen.

To actually fix your problem (sorry for only now getting to this smile), you can grant specific permissions to the Reporter in the permission scheme your project(s) is using. If you find the permission scheme you want to change and select "Grant Permission" a small window will pop up where you can choose who to grant the permission to. If you click "Show More", reporter is one of the options. So you should be able to only grant the "Edit Issues" permission to the reporter. You may also want to do this for "Link Issues" in order for the Epics to behave themselves.

Hope that helps,


As I said, granting the "edit permission" (and/or the "link permission even if it's not required in this case) to the "reporter" doesn't do the trick : only adding group or role is working in that specific case.

Moreover as a "reporter" granted whit "edit permission" one simply cannot edit Epic Link field!


Does anyone else see the same behavior? Any feedback?

I've experienced this also. I think it should be possible for the reporter to add an epic link. I'd like to know if this is a bug or if there is a workaround.

Hi Rick,

    Do you have any fix for this issue?

+1! I'm also experiencing the very same behaviour.

+1 : I'm facing the same problem.


If I set up the "edit permission" to a group or a role, it is then possible for people that belong to this group or role to create a ticket while setting the value for "Epic link" field. But this same behaviour is not working when the "reporter" is set with the same "edit permission". In fact I can see in the history of the ticket that the "Epic link" field is receiving its value just after the ticket creation. By the way as a "reporter" I cannot change the "Epic link" of a ticket I've created before even if I have the "edit permission"! That sounds like a bug to me...


Is there any solution / bug fix for this issue?

Paul Thomas is right.  Edit Issues is required.  It is a bug within JIRA that allows you to still visibly look like you are going to edit the field, but it will silently fail.

Same problem here:

- We have an Epic A in project A with reporter A

- Any reporter has edit permisson in project A.

- During the creation of a new issue (issue B for instance), reporter B see the Epic A as selectable, and the issue is created. But finally this information is not saved.

- I've tested that if reporter B is also reporter fo the Epic A, then it works.

Conclussion, to be able to use Epics by the reporters, the permissons must allow to Edit both the Epic and the issue to be included in the Epic. I think a new permisson of "Edit Epic Link" should be included in JIRA, to manage permissons separately.

Same Problem here as well,


Is there any open ticket with atlassian on the same. Or can we raise a ticket with them?

I agree on the child issue's project I need Edit permission because EpicLink field is updated, but for parent project (where Epic resist) "Link issue permission should be enough ! Edit is to much !

Any new about this? is solved in new versions?

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,312 views 14 20
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot