Why does Bamboo throw an exception when attempting to configure use of JIRA user repository

I am attempting to resurrect a previous Bamboo (version 3.4) installation after a failed update to Bamboo 4.2. Previously, Bamboo had configured Application Links to JIRA and used the JIRA user repository.

Now, after having reinstalled Bamboo, any attempts to configure it to use our existing JIRA instance user repository, result in an exception is thrown:

Failed to change the active user repository: com.atlassian.crowd.exception.InvalidAuthenticationException: Application failed to authenticate

Crowd in not installed, only JIRA (version 5.0.6)

Do I need to perform some task in JIRA prior to trying to configure Bamboo to use the JIRA user repository?

4 answers

1 accepted

Hi David,

Have you configured HTTPS for Bamboo or for JIRA? If yes, you need to use the same matching key to configure them to talk to each other. Also, what user base do Bamboo and JIRA have? Do they trust each other? Depending on that, you need to choose an autherntication method as per this document: https://confluence.atlassian.com/display/JIRA/Configuring+Authentication+for+an+Application+Link.

Are you using the same hostname - Base URL (Administration -> General Configuration page for each app) in the application link configurations? You can try using IP addresses instead of hostnames. Have you configured a context path: https://confluence.atlassian.com/display/BAMBOO/Changing+the+Root+Context+Path

Is there a proxy server in between Bamboo and JIRA that can block the communication?

If you still experience the same problem, please open a support ticket, answer the above mentioned questions and provide your Bamboo and JIRA logs after reproducing the problem.

Cheers,
Armen

Hello Armen,

Thank you for responding to my question. In answer to your questions:

No, I have not configured https for either JIRA or Bamboo (where would I check to confirm that this has not been set?).

Both applications have exactly the same base URL - they are installed on the same Windows 2008 server with no fire-wall, routing, proxy or bridging involved.

Bamboo is currently using the JIRA user repository. I applied the suggestion from the first answer to this question (by adding an entry for Bamboo in JIRA User Server configuration) to enable this.

I am unable to make the two applications trust each other, because the Application Links dialog does not give me that option. When I try to add a new Application link for Bamboo, a message appears on Step 2 of the wizard to say "This server does not support auto-detection"

I have edited the wrapper.conf file for Bamboo INST with the URL for Bamboo.

None of this has helped so far.

Which logs do you require to investigate this further?

Hello again Harry, I have tried to configure Application Links from the JIRA side without much success so far. When I click on the Application Links link from the Bamboo end it comes up with a 404 error:

"Problem accessing /plugins/servlet/applinks/listApplicationLinks. Reason: Not found"

Does that help?

Have you tried configuring from both the JIRA side and the Bamboo side? You can find out if you are using https if the URL you use the access the applications have https or http.

Hi David, that sounds like the Application Links plugin failed to start for Bamboo. I'd definitely check the Bamboo logs for something related to it to see what the error is.

It's definitely / and not /http://kojira:8085 - this is the context path and not the actual absolute URL. You might like to raise an issue with Atlassian support, but it sounds like this version is restricted to Java 6 as a dependency. I think only later versions of Bamboo support Java 7. That's the issue.

A bit more information - after editing the bamboo wrapper.conf entry to wrapper.app.parameter.4=/http://kojira:8085 - I could no longer access the Bamboo web site. Not until I return that entry to wrapper.app.parameter.4=/ can I access that URL. Is that syntax correct? - it sure looks a bit odd.

I have also attached the latest bamboo logs (atlassian-bamboo.zip.log)

Thanks again Harry, I'll install Bamboo 4.2 and see if I have any better luck tomorrow.

The correct answer is that Bamboo version 3.4 does not support Java 7

0 vote

Hi David,

The JIRA integration for User Management should not be impacted by the AppLinks.

The User Management integration settings are stored at files:

  • /BAMBOO_HOME_DIR/xml-data/configuration/atlassian-user.xml
  • /BAMBOO_HOME_DIR/xml-data/configuration/crowd.properties

Please open the files and check if they are consistent. If you would like us to check them for you, please create a support ticket at http://support.atlassian.com and we will be happy to help.

Regarding the JIRA side, you will need to make sure that an entry for Bamboo exists in the JIRA User Server configurations. The details in the Bamboo entry in JIRA must match the details from the "crowd.properties" file mentioned above (AppName and Password).

If you decide to create the support ticket, please remember to include the Bamboo Server logs.

Cheers,

Renan

Hi Renan, many thanks for the follow-up on this. I have now managed to configure Bamboo to use the JIRA user repository. Bamboo did not exist in the JIRA User Server list, and I was able to complete the configuration after adding it.

I have moved to the next step of trying to add a TrustedApplication Application Link in JIRA. This has proved troublesome. When adding the link the work flow and dialogs seem quite different to adding Confluence and FishEye Application Links.

After entering the server-name:8085 in Step 1, the Step 2 screen displays a message "This server does not support auto-detection".

After entering Application Name (Bamboo) and selecting Application Type (Bamboo) the Application Link is created, but with None for Incoming and Outgoing authentication.

When I attempt to configure the link, Outgoing Authentication displays a message:

"Bamboo" (Bamboo) is not registered as a service provider and "Sysmex NZ JIRA" (JIRA) cannot make requests using OAuth.

Enter the service provider details, the consumer key and shared secret provided by "Bamboo".
..and requests a number of details such as Service Provider Name, Consumer Key and Shared secret.
Somehow this does not seem correct. Surely Bamboo should be able to attain TrustedApplication status without such details?
Or do I need to make changes to the Bamboo configuration to enable it to support "auto-detection"?

That definitely says that the servers cannot talk to each other or some other error has occurred. Did you find anything relating to this in the logs? You shouldn't need to enter those details.

Hi David,

Thanks for providing your logs. I see that you are not using the correct version of JDK:

2012-08-30 14:10:31,357 ERROR [WrapperSimpleAppMain] [PluginEnabler] Unable to enable plugin com.atlassian.upm.atlassian-universal-plugin-manager-plugin
com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.upm.atlassian-universal-plugin-manager-plugin
	at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:445)
	at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237)
	at com.atlassian.plugin.impl.AbstractDelegatingPlugin.enable(AbstractDelegatingPlugin.java:215)
	at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114)
....
Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.upm.atlassian-universal-plugin-manager-plugin [42]: Unable to resolve 42.0: missing requirement [42.0] package; (&(package=com.atlassian.plugins.rest.common)(version>=1.0.5)) [caused by: Unable to resolve 34.0: missing requirement [34.0] package; (&(package=javax.activation)(version>=0.0.0.1_006_JavaSE)(version<=0.0.0.1_006_JavaSE))]
	at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
	at org.apache.felix.framework.Felix.startBundle(Felix.java:1709)

What version of Java do you have (you can run "java -version" from command line to check)? Try to specify the full explicit java path in your BAMBOO_HOME/conf/wrapper.conf:

wrapper.java.command=_explicit_path_to_java_

Also, try to set the JAVA_HOME environment variable. If you are still experiencing the same issue, please open a ticket with us, and provide the Bamboo logs again. In addition, provide the wrapper.conf file. If the issue persists, we can do a screen sharing session and investigate the problem together.

Cheers,

Armen

Hey David,

In addition to my previous comment, if you are using JDK 1.7, try to downgrade it to 1.6 and see if that fixes the issue. I suspect the problem to be related to this: https://jira.atlassian.com/browse/BAM-10704.

Cheers,
Armen

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

240 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you