Why arent my Bamboo Gadgets displaying in Jira?

I'm connecting the latest version of Jira (6.1) to the latest Version of Bamboo (5.2) and issue sharing, build display etc is working fine. However the gadgets for dashboards only display a blank box...

The jira server is running over https, bamboo is just straight http. I've tried with the Jira Bamboo plugin, manually subscribing (as per the confluence wiki). Pointing towards the CNAME address, the machine:port dns address and the ip:port address and get the same results every time :( Its not essential to our use of Jira, but it would be nice if all the features worked!

Any help greatly appreciated :)

2 answers

1 accepted

This widget could not be displayed.

Hi Dan,

Have you already tried to bypass your JIRA's HTTPS access to verify if the problem continues (you can test this by accessing JIRA directly on the server via localhost:PORT)? Also, how is your application link between JIRA and Bamboo configured?

One possibility is to do the following:

  1. Delete the existing application link
  2. Create a new application link between JIRA and Bamboo but instead of the domain name try to use the IP:PORT of each application to configure the link (only if they are running in the same network)
  3. If everything runs fine after the test above (which will bypass SSL, proxy configurations, etc.) you can keep the configuration like this (using IP:PORT) and then only modify the "Display Name" of the application link to use the actual domain name with SSL. By doing this, the applications will have a direct communication channel without SSL/proxy usage and anyone that needs to use the Application Link feature will only be able to use it through the domain URL.

If this doesn't help you, you can raise a support ticket with us in support.atlassian.com and we will be glad to troubleshoot this further with you!

Cheers!

Hi Pietro,

Thanks for getting back to me.

I've done as you've suggested and thats exactly how I got the application link to work in the first place. Literally everything else works fine and seemingly even the gadget subscription (if added manually) seems to setup ok, its just that when I try to view the gadgets, I just see a blank box. I think I may raise a support ticket if theres nothing else I can try. :(

Ok, so in a complete fit of stupidity, I have found the problem. It turns out, google chrome was blocking the bamboo rest gadget urls. Because our installation of bamboo isnt running https (where as Jira is) it was blocking them because they were from an "insecure" source. So in fact, this has probably always been working, just didnt notice the little grey shield in the address bar in google chrome. Incidentally, firefox works perfectly without any issue.

This widget could not be displayed.

So I ran into this on Firefox 26.0; enabling the insecure content fixed the gadgets. Although, what I find odd about that specifically is that the Fisheye gadgets, also from an insecure source, don't have this problem.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

277 views 5 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you