Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why are not projects imported on a successful import?

This question is in reference to Atlassian Documentation: Migrating from JIRA Server to JIRA Cloud

I am trying to migrate from an existing JIRA server instance full of projects to a cloud instance.  I have been able to successfully export the JIRA server instance and import it onto the cloud.  The problem I am having is none of the projects are showing up.  

For the initial tries I attempted a straight export and import, this failed with invalid characters in the CDATA of the xml.  

To successfully import the file to the cloud I used the Atlassian tool to remove the invalid characters. Unzipped the file, ran the tool, added the data folder for attachments and avatars the zipped it back up, and imported. This worked but the projects never appeared.  Is this normal? Is there something I am missing?

I have successfully updated from v6.4 (server) to v7.2 (server) and restored on v7.2(server) everything worked out fine but moving from the server (v7.2) to the cloud is not working out.  

2 answers

I have the same problem, did someone solve it?

The problem for me was when I was rebuilding the zip file.  I basically built an invalid zip file that had an additional file layer. The file tree for me was backup.zip->backup->data, when it should have been just backup.zip->data

thahn

That did the job, thanks. I ziped the folder containing the files instead of just zip the files directly. 

A couple questions:

  1. Assuming you're running JIRA Agile, did you update it to 6.7 before trying the import?
  2. Did you verify that your user (possibly via groups) has been granted access to the relevant Application (JIRA Software, JSD, JIRA Core?)

 

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you