Webhooks stopped working.

Hi JIRA support representative,

JIRA Version: (v6.3.6#6336-sha1:cf1622c) 


We have several webhooks to slack channels and suddenly they all stopped working and posting to slack channels. The webhook URI have been changed to sending to requesb.in and I also tried to use TCPDUMP on the interface to try to get network packets leaving server interface (eth0) but we dont  have success, nothing is showed on tcpdump (syn packets to destiny)

 

JIRA is showing  "Posting to web hook at " on the logs but dont initiate outbound connections to slack, requestb.in or something else configured as webhook destiny: 

 

[root@ip-10-7-1-14 log]# tail -f /u/jira/atlassian-jira-6.3.6-standalone/logs/catalina.out 

2017-01-12 10:15:07,381 http-bio-8081-exec-16870 DEBUG hery.victor 615x6571137x2 1edsidx 186.215.119.74 /secure/WorkflowUIDispatcher.jspa [webhooks.plugin.impl.PluginUriResolverImpl] Found new URI from OSGi service, 'Optional.of(http://requestb.in/1mzytru1)'


2017-01-12 10:15:07,382 http-bio-8081-exec-16870 DEBUG hery.victor 615x6571137x2 1edsidx 186.215.119.74 /secure/WorkflowUIDispatcher.jspa [webhooks.plugin.impl.PluginUriCustomizerImpl] Found new URI from OSGi service, 'http://requestb.in/1mzytru1'

2017-01-12 10:15:07,534 pool-15-thread-3 DEBUG anonymous 883x6542483x10 8cfuf 186.215.119.74 /secure/QuickEditIssue.jspa [atlassian.webhooks.plugin.PublishTaskFactoryImpl$PublishTaskImpl] Posting to web hook at 'http://requestb.in/1mzytru1?user_id=hery&user_key=hery', body is:

 

I would like to check if anyone else has seen this or have something to help solve this problem.

 

B. Regards,

Alfredo Tomio JR

+55 48 996 320 369

 

 

 

2 answers

This widget could not be displayed.

Alfredo, this has happened to me for months now, it used to be that a restart would fix it, but then randomly they would stop working.  This was also posting to Slack.  In fact now, when we restart, they would for a few hours and then just stop.

I've confirmed that our JIRA on-prem server can still post webhooks, so it definitely appears to be application related.  At this point, i'm just hoping that once we upgrade to JIRA 7.X that it will resolve the issue, pretty clueless as to why it happens.  I posted a similar question in the past, but unfortunately didn't get any traction.

This widget could not be displayed.

We have the same issue with our on-premisses Jira. Webhooks just stopped working, and we have no way to debug them or find out what is going on. 

 

We are missing some better testing and reporting functionality (For example in other tools, you can try to resent the latest webhook, or sent a test one, or see logs of the last X webhooks that were sent out)

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

189 views 3 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you