View in Issue Navigator link is not working (GH 6.1.6 & ScriptRunner 2.1.3)

Hello:

I hope @Jamie Echlin can help me! I have all latest versions installed on our served version of JIRA. Here is the info:

JIRA (v5.2.9#852-sha1:71473fa), GreenHopper (v6.1.6), Script Runner (2.1.3).

I am getting the following error message when I click the "View in Issue Navigator" link in the PLAN mode of all of our project/team boards in JIRA/GreenHopper:

sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target.

Here is what my browser displays when the link launches the Issue Navigator and the error appears:

https://bugs.corp.bbi.com/issues/?jql=issueFunction%20in%20inSprint(%22Slacker%20Site%22%2C%20%22Sprint%2030%20-%20Website%22)

Please help! I've contacted Atlassian support and they're directing me to Jamie, the plugin developer.

Thanks in advance!

andria

2 answers

1 accepted

1 votes
Ahmad Danial Atlassian Team Apr 11, 2013

Hey there, Andria.

The problem that you are facing could be caused by the fact that JIRA does not contain the SSL certificate (public key) from the services it trying to connect.

Is your POP mail server using SSL services? If so, can you try to obtain that certificate (public key) from the mail server and then import into the keystore of the JAVA which JIRA is using at the moment.

After that, restart JIRA and try to test the connection again.

Kindly check on the documentation for further details and explanations:

Hope this helps.

Warm regards,

Danial

Danial:

This worked!! Thank you!!

..andria..

Brilliant, thanks for answering this Ahmad.

Ahmad Danial Atlassian Team Apr 14, 2013

Hey there, Andria and Jamie.

Glad to be able to help on this. You are most welcome!

Warm regards,

Danial

I don't understand what to do. My JIRA runs on Windows, on SSL with a valid certificate. Not sure how would this greenhopper issue be connected to POP or LDAP when JIRA is basically trying to connect to itself.

First I exprted the certificate from a linux machine that has openssl installed:

$ openssl s_client -connect jira01.domain.com:https

I took the cert, copied over to the JIRA server. Then imported the SSL certificate into JIRA's keystore although it was already there hence running on SSL:

C:\JIRA\jre>bin\keytool -import -file "C:\certificate\https.pem.txt" -alias jira01.domain.com -keystore c:\certificate\jira.jks

...

Certificate already exists in keystore under alias <tomcat>
Do you still want to add it? [no]:  yes
Certificate was added to keystore

Rebooted JIRA but same error. What do?

You have to import the JIRA server's certificate into the keystore, not the email server's cert. The script runner turns back to JIRA, an needs the root cert in the keystore.

Of course if the email server's root cert is the same as JIRA's cert, then there is no difference.

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,796 views 11 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot