Using Script Runner to send custom email with a custom user picker field, won't work when null

I am setting up a workflow with multiple Custom email being sent via Script Runner.  I am using 2 custom User picker fields, one for the To: section of the email and the other for the Cc: section.

 

Everything is working fine except when no user is entered into one of the fields, the script throws a java Null error and no email is sent out.  Is there a way around this?  There may be times when no CC user is required, and I was trying to avoid making those fields mandatory and forcing users to always enter a user even if one is not required.

 

Thanks

 

1 answer

It is working on my side: had both custom fields in "To Fields" one was filled, the other empty. The email was sent.

Which version of scriptrunner are you using? I'm on 3.0.10

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Sunday in Agility

You asked for it, so we delivered: images on issues have arrived

A picture tells a thousand words. And agility boards have just released their latest feature: cover images on issues – so now your board can tell a story at first glance. Upload attachmen...

340 views 3 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you