Users facing 500 and Error rendering WebPanel after upgrade JIRA from 6.4.14 to 7.2

After upgrading from JIRA Server 6.4.14, the admin is getting this error, that makes the use of the menu unavailable.

          Error rendering WebPanel (:button-resources-init/JIRA.Feedback.Plugin.button): Unable to compile Soy templates at: com.atlassian.feedback.jira-feedback-plugin:button-resources-init

Other users are getting a 500 error when trying to access JIRA, and this is the detail:

java.lang.RuntimeException: javax.servlet.ServletException: java.lang.RuntimeException: javax.servlet.ServletException: java.lang.IllegalArgumentException: Root page 'com.atlassian.jira.gadgets:dashboard-page' does not exist

 

2 answers

Hi, I'm facing the same issue.

Here's the error in the backend:

    Error rendering WebPanel (:button-resources-init/JIRA.Feedback.Plugin.button): Unable to compile Soy templates at: com.atlassian.feedback.jira-feedback-plugin:button-resources-init

Users are getting http/500 in the frontpage. The control panel / admin backend is functional.

Did the full upgrade of plugins. I'm also running Service Desk.

 

JIRA Software: 7.2.4 (.bin upgrade)

JIRA Service Desk: 3.2.4 (upgrade from control panel)

Ok, I just got word from Atlassian Support.

If you are seeing a lot of this in your catalina.out:

'com.atlassian.streams.streams-jira-plugin' - 'JIRA Activity Stream Plugin' failed to load.
The plugin has been disabled. A likely cause is that it timed out during initialisation

 

It seems that most of your System plugins are failing to startup due to time out limit reached.
I suggest you to try increasing the plugins timeout, by adding the following startup option in your JIRA options: 

-Datlassian.plugins.enable.wait=300 

as in Setting Properties and Options on Startup, then restart JIRA.

If the plugin timeout does not help, there is also the possibility of a third-party plugin is delaying the system plugins startup, that being said I suggest you to bypass all your third-party add-ons, by moving the content of the folder jira-home/plugins/installed-plugins to a backup folder, then try to restart JIRA once more.

That worked for me, I hope that helps you too.

Best regards,

Leonardo

 

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Monday in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

685 views 6 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you