Upgrade JIRA from 4.1.2 to 5.1.7 and move database from MYSQL to Oracle 11g

Dear Support,

We try to upgrade JIRA 4.1.2 to 5.1.7. This was performed well by exporting data to xml on JIRA 4.1.2 system then importing it to JIRA 5.1.7 (the 5.1.7 is on other machine than 4.1.2 and both have MYSQL databases).

Second step we try to export the JIRA 5.1.7 data to xml on MYSQL database and import it to JIRA 5.1.7 on Oracle 11g database.

After the import of xml data was performed, the new system started but I can't login to it.

I follow these instructions:https://confluence.atlassian.com/display/JIRA/Retrieving+the+JIRA+Administrator

I change the password usig this command:update cwd_user set credential='uQieO/1CGMUIXXftw3ynrsaYLShI+GTcPS4LdUGWbIusFvHPfUzD7CZvms6yMMvA8I7FViHVEqr6Mj4pCLKAFQ==' where user_name='XXXX';

After JIRA restart got this error message:

JIRA Startup Failed

You cannot access JIRA at present. Look at the table below to identify the reasons

Description

NullPointerException

Delete the lock file and restart JIRA but the same error.

In the log file I descover this error message:

/var/atlassian/application-data/jira/log/atlassian-jira.log

2012-10-25 18:54:18,083 main INFO atlassian.jira.startup.JiraStartupLogger

********************************************************************************

JIRA 5.1.7 build: 786 started. You can now access JIRA through your web browser.

********************************************************************************

2012-10-25 18:54:18,140 main FATAL atlassian.jira.upgrade.UpgradeLauncher Skipping, JIRA is locked.

2012-10-25 18:54:18,140 main INFO atlassian.jira.scheduler.JiraSchedulerLauncher JIRA Scheduler not started: JIRA startup checklist failed.

2012-10-25 18:54:18,215 main ERROR jira.web.dispatcher.JiraWebworkActionDispatcher

******************************************

JIRA startup failed, JIRA has been locked.

******************************************

2012-10-25 18:54:53,287 Modification Check:thread-1 INFO atlassian.jira.startup.JiraStartupLogger

___ Modifications ___________________________

Modified Files : jira-application.properties

Removed Files : None

Thanks and regards:

Sándor Feernczi

System Administrator

TRASSET International S.P.A. - Milano, Italy

it@trasset.com

sandor.ferenczi@trasset.com

www.trasset.com

2 answers

This widget could not be displayed.

Hi Sandor,

I'm fear some misconfiguration happen in your end. It seem you converting xml backup from mySQL to oracle and i hope this will not caused the root problem.

Could you try to perform the following workaround?

  • Please make sure that the whole /var/atlassian/application-data directory is owned by the user that starts up JIRA.
  • Shut down JIRA and remove the plugin in <jira-home>/plugins folder. Then, Start JIRA
    • .bundled-plugins
    • .osgi-plugins
  • Ensure the latest Java 6 is install and the java home directory set up. Please try to re-create the jira home again.
  • You may need to have fresh installation again if the problem still persist.

Good Luck

Regards,

John Chin

We have 3 (virtual) machines all on LINUX OS:

1.JIRA 4.1.2 with MYSQL 5.1.41 - this is the LIVE environment

2.JIRA 5.1.7 (upgraded from JIRA 5.0.6) with MYSQL 5.5.25 – this is the TEST system with data from LIVE (xml export-import)

3.JIRA 5.1.7 with Oracle Database 11g – this is the TEST system for migrate to Oracle Database

I have performed an export on machine 1. and import the data to machine 3.JIRA 5.1.7 to JIRA 5.1.7.

Then export on machine 2. and import the data to machine 3. JIRA 5.1.7 to JIRA 5.1.7.

The same result.

How can I upload the catalina.out log file here?

Till now I tried to migrate JIRA from different versions to newer versions. All works perfectly except migration from MySQL database to Oracle (11g and 10g the same result).

Regards,

Sándor

I have tried your advise but the same results (plugin removed and verification of directory owner).

After restarting JIRA I got the same error.

Regards,

Sándor

This widget could not be displayed.

Hi Sandor,

According to the error message you have provided above, it appears that you JIRA instance has become locked. This can happen sometimes after performing upgrades, imports etc., but usually can be fixed easily. All you need to do is shutdown your JIRA instance and look in the JIRA home directory, typically:

/var/atlassian/application-data/jira

In a console/terminal window run "ls -al" and look for a file ".jira-home.lock". If it is present (after shutting down JIRA) then delete it. You should then be able to start JIRA normally; it may be a bit slow to start off with but be patient and it should come back fine (I think it takes a few minutes to sort itself out).

Regarding database migration, the Switching Databases document in the JIRA documentation may be helpful.

Good luck!

The case was resolved in https://support.atlassian.com/browse/JSP-142092 ticket.

Sándor Ferenczi

System Administrator

TRASSET International S.P.A. - Milano, Italy

it@trasset.com

sandor.ferenczi@trasset.com

www.trasset.com

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

106 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you