Unable to process plugin to generate OSGi manifest

Hello,

Im developing a menu plugin.

I'm using jira 4.2

When i finish the plugin, i do atlas-debug and it gives:

2013-09-24 11:23:17,151 localhost-startStop-1 ERROR      [atlassian.plugin.loaders.ScanningPluginLoader] Unable to deploy plugin '${project.groupId}.${project.artifactId}', file Unit: C:\Users\Luis Daniel\jiraSpace\B2bImportAndReportsSections\target\jira\home\plugins\installed-plugins\B2bImportAndReportsSections-1.0.jar (1380014280184)
com.atlassian.plugin.PluginParseException: Unable to process plugin to generate OSGi manifest
	at com.atlassian.plugin.osgi.factory.transform.stage.GenerateManifestStage.execute(GenerateManifestStage.java:154)
	at com.atlassian.plugin.osgi.factory.transform.DefaultPluginTransformer.transform(DefaultPluginTransformer.java:190)
	at com.atlassian.plugin.osgi.factory.OsgiPluginFactory.createOsgiPluginJar(OsgiPluginFactory.java:250)
	at com.atlassian.plugin.osgi.factory.OsgiPluginFactory.create(OsgiPluginFactory.java:162)
	at com.atlassian.plugin.loaders.ScanningPluginLoader.deployPluginFromUnit(ScanningPluginLoader.java:116)
	at com.atlassian.plugin.loaders.ScanningPluginLoader.loadAllPlugins(ScanningPluginLoader.java:89)
	at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:136)
	at com.atlassian.jira.plugin.JiraPluginManager.start(JiraPluginManager.java:52)
	at com.atlassian.jira.ComponentManager$PluginSystem.start(ComponentManager.java:1326)
	at com.atlassian.jira.ComponentManager.quickStart(ComponentManager.java:227)
	at com.atlassian.jira.ComponentManager.start(ComponentManager.java:212)
	at com.atlassian.jira.upgrade.ConsistencyLauncher.launchConsistencyChecker(ConsistencyLauncher.java:63)
	at com.atlassian.jira.upgrade.ConsistencyLauncher.contextInitialized(ConsistencyLauncher.java:42)
	at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4887)
	at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5381)
	at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
	at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:901)
	at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:877)
	at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:633)
	at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:977)
	at org.apache.catalina.startup.HostConfig$DeployWar.run(HostConfig.java:1654)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:439)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
	at java.lang.Thread.run(Thread.java:662)
Caused by: java.lang.IllegalArgumentException: Plugin version '${project.version}' is required and must be able to be parsed as an OSGi version - MAJOR.MINOR.MICRO.QUALIFIER
	at com.atlassian.plugin.osgi.factory.transform.stage.GenerateManifestStage.validateOsgiVersionIsValid(GenerateManifestStage.java:247)
	at com.atlassian.plugin.osgi.factory.transform.stage.GenerateManifestStage.execute(GenerateManifestStage.java:147)
	... 26 more

and in jira administration> plugins, it show:

${project.groupId}.${project.artifactId}

Descripción: 
Vendor: (unknown)
Plugin Version: 0.0
JIRA Version: 0.0
Installation Mode: Embedded
There were errors loading this plugin:
Unable to process pugin to generate OSGi manifest

Im noob in this and my english is so poor.

your help is welcome

Thanks!

6 answers

1 accepted

I tried a lot of changes in the pom, at finally i change the packaging to :

<packaging>atlassian-plugin</packaging>

The plugin did not break and then worked well

Thanks for your help

The naming of the plugin version should be proper in your plugin pom.xml. i had a similar problem...when i tried naming the version as "v1.0.0" i was getting similar error and when i changed the name of the version to "1.0.0" it worked like a charm!

Sorry, i don't get what he means by "compiled version isn't setting up the version string properly in Eclipse"

you give plugin version other than 0.0 and check.

have a doubt what is <jira.version> in your pom.xml

Im using 4.2

I attach the pom properties

&lt;properties&gt;
		&lt;jira.version&gt;4.2&lt;/jira.version&gt;
		&lt;jira.data.version&gt;4.2&lt;/jira.data.version&gt;
		&lt;amps.version&gt;4.1&lt;/amps.version&gt;
	&lt;/properties&gt;
&lt;/project&gt;

Hello Daniel; have you updated your atlassian SDK to the last version?

Thanks!

Hello Jaime,

Yes i have updated it, and it still crashing

0 vote

For me it was having a version of the plugin that looked like "1.0." instead of "1.0.0"

For me it as <application-version> tag. changing it from 

&lt;application-version min="6.2" max="6.4.12"/&gt;

to

&lt;application-version min="6.2" max="6.4"/&gt;

solved it.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Jira

Meet the AUG leaders of Northern Virginia

@Rachel Wright (Jira Genie), @Billy Poggi (AUG NOVA, DC), and @Dana Jansen (Confluence Queen) are just some of the folks that lead one of the world's most active Atlassian User Group (AUG)....

137 views 5 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you