Unable to login to local JIRA after onDemand Restore

I am currently trying to merge a few JIRA onDemand instances together. I saw that the best way to do this was to create a temporary local enviroment, restore a onDemand instance, use the project import tool for the rest, and restore into onDemand. However after I restore the first JIRA onDemand xml backup to my local JIRA, I can no longer log in. I have tried my onDemand username/password, sysadmin/sysadmin, and I have even changed the postgresql database entry to sysadmin/sphere. I still cannot log in?

3 answers

1 accepted

I ended up having to work with my old offline 4.2.1 backup and upgrade it by itself to 6.2. From there I was able to import the other onDemand instances via the project importer and fix the rest manually. Not the most ideal solution but I did not have to redo all of tickets.

Hi Justin,

This guide gives you the information you need: Cannot login as sysadmin after import backup from JIRA OnDemand to JIRA Standalone and provides another link to Retrieving the JIRA Administrator manually too.

Cheers,
Mauro

Thanks for the response!

I did read the document you linked and had set the database for credentials sysadmin/sphere to no avail. I opened up the logs and finding it trying to authenticate beyond my network? Does this have something to do with crowd?

atlassian-jira-security.log:

2013-12-16 22:41:59,739 http-bio-8080-exec-10 anonymous 1361x45x1 8stpk8 10.10.0.27 /rest/gadget/1.0/login login : 'sysadmin' tried to login but they do not have USE permission or weren't found. Deleting remember me cookie.

Justin,

That error seams like a noise error as reported on this improvement request: SER-184

I would say that the password was not correctly changed or maybe Jira wasn't restarted afterwards. I had to do that in the past and manually changing the password should always work as a last resource.

If it keeps failing, I would recommend starting again from scratch. New database.

Best of luck,
Mauro

Alright, I have done a bit of playing around with it. It seems to be specific to the export from onDemand. I can export another, smaller onDemand and do everything normally. However, when I import my larger onDemand instance I cannot log in no matter what I do, even with password database injection. Nor does the project importer reconcognize it as a a vaild xml backup.

There could be one or several factors causing the problem so I would suggest creating a Support request for Jira and see if the Jira Support team can assist you better.

You can do that at support.atlassian.com

Cheers!

0 votes
Colin Goudie Community Champion May 13, 2014

In our case, the cwd_* tables had incorrect directory id.s

Basically you can fix it by running something like

delete from cwd_directory_attribute where directory_id <> 1;

delete from cwd_directory_operation where directory_id <> 1;

update cwd_group set directory_id=1;
update cwd_group_attributes set directory_id=1;

update cwd_user set directory_id=1;
update cwd_user_attributes set directory_id=1;
update cwd_membership set directory_id=1;

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,880 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot