Unable to Connect GitHub Organization to JIRA using DVCS Connector

Hello,

I set up an Application under my GitHub Orgnization to retrieve my oAuth Client ID and Client Secret. (I used "https://{myid}.atlassian.net" as the two URLs that need to be specified for the Application.)

When I go to "Manage DVCS Accounts" and attempt to link up the GitHub Application with the JIRA DVCS connector using my GitHub Organization name, Client ID and Client Secret, I get the following error:

Invalid credentials, please reset OAuth settings

I tried resetting it on both the JIRA and GitHub sides, but no luck.

Could you please help?

6 answers

1 accepted

The issue has been fixed in the 1.4.3 version.

Miroslav, I just tried again and got the following error:

Failed adding the account: [Error retrieving list of repositories]

I tried and got the same thing....3 years later

In JIRA 5.0 do not have an upgrade of the plugin. How to do in this case? Because that error is the same we have here, but in JIRA 5.0.2.

Which version of the connector are you using?

the last one supported to JIRA 5.0.2: 1.4.0.1

1.4.0.2 bug fix version has been released. Could you try this one?

Great Mrs. Stencel. Now it's working.

Thank you for the quick upload the 1.4.0.2 version.

0 vote
Jason Worley Atlassian Team Oct 08, 2013

This appears to be a new issue that is currently being reviewed. Sorry I don't have more details for you except to watch this issue for updates: https://jira.atlassian.com/browse/DCON-324

Hope this helps!

It might be that the access token was rewriten with a wrong value. You must regenerate access token on the account. To do this:

  1. login to Github with the account you want to grant access to (you don't have to do this now, but make sure that you are not logged in with wrong account)
  2. go to the Manage DVCS Accounts page in Jira
  3. press Reset OAuth settings for the account (in the cog menu)
  4. check the key and secret there, fill it if it is not set
  5. press Regenerate Access Token button
  6. if the application was not granted before, Github will ask to grant permission for the application

I've tried this but no luck.

I receive the following when adding it fresh

Failed adding the account: [Error retrieving list of repositories]

then if I refresh the page and try to refresh the repos i get

Error when refreshing account 'xxxxchris'.

Attempting to regenerate the access token does nothing but refresh the page.

Chris, we asked Atlassian to upgrade our DVCS connector to 1.4.3, and now everything's working great.

Manually updated, had to go to the version history page as it was not listed in the add-on marketplace by default. Once manually updating all was well, thank you.

How exactly would you go about manually updating the plugin? I tried replacing the old one and removing the .osgi transformed one and then starting up jira again. But it still shows the old version...

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published 33m ago in Jira

5 ways you can make the most of Jira Software and Bitbucket Cloud

As part of the Bitbucket product team I'm always interested in better understanding what kind of impact the use of our tools have on the way you work. In a recent study we conducted of software devel...

9 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you