UPM "Purchased Add-ons" does not work when behind a proxy and timeout errors in logfile

UPM plugin version 2.12.2, Jira 6.0.5

Our log file contains lots of timeout errors caused by UPM.

2013-08-01 13:39:51,874 QuartzScheduler_Worker-2 WARN ServiceRunner    RemotePluginLicenseNotificationPluginJob-job [atlassian.upm.notification.PluginLicenseNotificationCheckerImpl] Automatic license update check failed: com.atlassian.upm.mac.HamletException: org.apache.http.conn.ConnectTimeoutException: Connect to marketplace.atlassian.com:443 timed out

We configured the proxy server as described in this KB article: https://confluence.atlassian.com/display/JIRAKB/How+to+Configure+an+Outbound+HTTP+Proxy+for+JIRA

The Marketplace itself does work: I'm able to browse, download and install plugins.

When I try to acccess the "Purchased Add-ons" page, I can supply my Atlassian login credentials, after login the dialog disappears, and after a while it pops up again and it reports "Sorry, an error occurred while attempting to refresh your purchased add-ons list."

I investigated the source of the MarketplaceClientConfiguration.class. It turns out it is only taking the http.proxyHost / proxyPort System Propery into account, it does not set the proxy configuration for HTTPS (defined with https.proxyHost / proxyPort).

com.atlassian.upm.pac.MarketplaceClientConfiguration (atlassian-universal-plugin-manager-plugin-2.12.2.jar)

...
 String proxyHost = getSystemProperty("http.pac.proxyHost", "http.proxyHost", null);
    if (proxyHost != null)
    {
 ...
// no setting for https.proxyHost

I see no possibility to workaround this. We would like to connect to the Marketplace, access to "Purchased Add-Ons" would be nice, but we do want to get rid of the logs regarding the timeout.

Please assist. Atlassian Support redirected me to here, because for some reason the use of a proxy server is considered as "Third Party".

6 answers

1 accepted

This widget could not be displayed.

Hi all,

Sorry for the radio silence on this one. We've filed this bug as https://ecosystem.atlassian.net/browse/UPM-3949. It's been fixed in UPM 2.13, which should be out in the next week or so.

cheers,

John

While attempting to update the UPM to 2.1.3, I get the same error ('...Connect to marketplace.atlassian.com:443 timed out' etc.). Any suggestions on how to update the plugin so I can update other plugins?

The preceding occurred in a standalone test instance (clone of PROD) but with no internet connectivity - I downloaded UPM 2.1.3 to my workstation for testing on an evaluation license (uploaded using the 'Upload Add-on' button).

The test server will not be allowed to connect to the internet for many reasons.

Installed 2.13.1. The Purchased Add-on, now does not work anymore (no login prompt for My Atlassian). It now shows an empty page.

What has been fixed now: no more errors in the log file.

Ben Woskow Atlassian Team Aug 26, 2013

Hi Jan-Willem,

I filed https://ecosystem.atlassian.net/browse/UPM-4014 to look into the missing login prompt. We'll take a look shortly. If you have any additional information such as your browser information or your JIRA/Confluence license type, please add it to that issue.

Cheers,
Ben

Hi Ben,

I don't have access to ecosystem? Can't use my Atlassian ID to login, nor have a OnDemand account.

Jira 6.0.7, Unlimited Users License.
Tested with both Firefox and Chrome.

This Resource not found error appears in the log (one time only, not repeating for subsequent attempts):

2013-08-27 09:49:47,308 http-bio-9090-exec-1 WARN anonymous 589x9823x3 1gklrux 10.161.238.121 /s/en_US-mxzyor-1988229788/6106/5/2.13.2/_/download/batch/com.atlassian.upm.atlassian-universal-plugin-manager-plugin:upm-purchased-addons/com.atlassian.upm.atlassian-universal-plugin-manager-plugin:upm-purchased-addons.js [atlassian.plugin.servlet.AbstractDownloadableResource] Resource not found: Resource: com.atlassian.upm.atlassian-universal-plugin-manager-plugin js/marketplace/search/results/MarketplaceAddonView.js (null)

When checking the jar file (v2.13.2) there is indeed no such file "MarketplaceAddonView.js" in that path, that file is located in "js\marketplace\addon\"

Update
Created ecosystem account, but get a "Permission Violation" when trying to access the issue you mentioned (UPM-4014).

Ben Woskow Atlassian Team Aug 26, 2013

Jan-Willem: I've added your feedback to the issue and fixed the permission problem. You should be able to see the issue now.

Ben Woskow Atlassian Team Aug 30, 2013

The Purchased Add-ons feature is fixed in UPM 2.13.3, now available on the Atlassian Marketplace.

This widget could not be displayed.

Closing question.. No answer...

This widget could not be displayed.

Hi,

Ive got the same problem while setting the Atlassian SDK environment (maven). The problem -as far as I know- is that you can-t access to httpS sites behind a proxy, not related to atlassian but all apps using http.proxy properties ...

(some of the maven repos host in atlassian are running with httpS)

In my case I had to switch to another LAN without proxy, update the maven dependencies and then switch to the original network. In your case this could not be acceptable, but note that the scope of this problem may be wider than atlassian products.

Here is a workaround setting the https.* system properties:

https://answers.atlassian.com/questions/31384/plugin-sdk-proxy-setting-for-https-is-not-working-but-http-is

HTH

Hi Alex, thanks for your comment.


That was another issue I was having, however that is related to Maven not able to apply both http and https proxy settings. I worked around that issue by setting both the http.proxy* and https.proxy* system properties in mvn.bat (suggested in answer tou mentioned), which worked well. Another option was to run maven multiple times, alternating the proxy setting for http and https, until all dependencies were downloaded.

Issue here is that the UPM does not use / "see" the https.proxy* settings at all, only the http.proxy* properties are used.

Setting the https.proxy* therefore does not work in this case, while it could be easily implemented. Lots of applications can work with a HTTPS proxy, they just need to offer the ability to configure both HTTP and HTTPS proxy settings.

This widget could not be displayed.

Would also be happy to know how to suppress the logging about the timeout.

Tried several variations of entries in logging.properties

atlassian.upm.notification.PluginLicenseNotificationCheckerImpl = OFF
atlassian.upm.notification.PluginLicenseNotificationCheckerImpl.level= OFF
com.atlassian.upm.notification.PluginLicenseNotificationCheckerImpl = OFF
com.atlassian.upm.notification.PluginLicenseNotificationCheckerImpl.level = OFF

None of the above helps to suppress the log.

UPDATE

I deleted the "RemotePluginLicenseNotificationPluginJob" Service, under System->Services. It does not run anymore, hence it does not generate warnings in the log.

This widget could not be displayed.

Any clue? Or can't this be solved in the "Third Party-world" and should I wait until Atlassian add support for HTTPS proxies for the UPM plugin?

This widget could not be displayed.

I did a pull through the list of bug surrounding https proxy on https://jira.atlassian.com/ without joy.

This sounds like a bug or at very least a feature request for the marketplace team.

I'm throwing some upvotes at this issue to see if we can get anyone on the marketplace team to weigh in here.

You may want to create a support ticket on https://support.atlassian.com

That way things will be firmly in Atlassian's court. I'd mention this post in your request. If you do get an answer please get the information back into this post. I don't immagine that you are going to be the only person with this question.

Or John could completley take care of it....

Thanks Daniel for your effort! You were right it sounded like a bug! ;)

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

218 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you