Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

UPM not working correctly after Update to 8.5.1

Hey,

we just recently updated from 7.13 to 8.5.1 and everything at first seems to work fine, but the UPM.

There is no obvious Error shown. All the checks are fine and verified.

The problem is now that the "update" and "update needed" buttons/banners in "manage apps" are missing.

Also the "install" button in "search apps" is shown but if you click on it nothing happens.

At last what we found out is that the screenshots if you open a tab of an app are not loading ("retrieving screenshots" only) and the only details we get are:

Version: 1.21.1

(Provider) Hersteller: Atlassian

(Key) App-Schlüssel: com.atlassian.troubleshooting.plugin-jir

 

so i have read alot about upm in the past days. Already checked for proxy, base-url etc. It is also able to reach the marketplace since i can search and find apps.

Maybe it is not even upm but some other plugin that´s interfering that i´m not aware of?

Last hint: After the upgrade our upm version showed 4.08, on marketplace only 4.07 is listed. Also upm is now a system App it was a User App in 7.13.

Ofc we followed the Process of disabling it or trying to remove it as .jar before upgrading. We tried alot as I said.

Also clreared the plugin cache few times. Nothing worked.

 

i would aprreciate some thoughts

greetings

1 answer

Hello,

Same issue.

We are upgrading from a 7.13 to a 8.5 on our testing environment.
After upgrading our node1, we are upgrading the apps as per the recommended fight plan.

The UPM apps is currently 4.0.8 and using the admin screen, we are able to update to 4.0.13.
Running the update, we have the following error message : An error was encountered while updating the UPM. See the logs for more details.

In the logs, we have a log telling us that we are trying to update UPM from 4.0.8 to 4.0.8.

[c.a.plugin.manager.DefaultPluginManager] Updating plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-selfupdate-plugin' from version '4.0.8' to version '4.0.8'
2020-02-04 10:11:25,811+0100 UpmAsynchronousTaskManager:thread-2 INFO pch 606x316x3 1v002e8 172.22.92.139 /rest/plugins/1.0/installed-marketplace [c.a.plugin.manager.DefaultPluginManager] Disabling com.atlassian.upm.atlassian-universal-plugin-manager-selfupdate-plugin
2020-02-04 10:11:25,934+0100 UpmAsynchronousTaskManager:thread-2 DEBUG pch 606x316x3 1v002e8 172.22.92.139 /rest/plugins/1.0/installed-marketplace [c.a.activeobjects.osgi.ActiveObjectsServiceFactory] onPluginDisabledEvent removing delegate for [com.atlassian.upm.atlassian-universal-plugin-manager-selfupdate-plugin]
2020-02-04 10:11:25,949+0100 UpmAsynchronousTaskManager:thread-2 INFO pch 606x316x3 1v002e8 172.22.92.139 /rest/plugins/1.0/installed-marketplace [c.a.plugin.loaders.ScanningPluginLoader] Removed plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-selfupdate-plugin'
2020-02-04 10:11:25,992+0100 UpmAsynchronousTaskManager:thread-2 INFO pch 606x316x3 1v002e8 172.22.92.139 /rest/plugins/1.0/installed-marketplace [c.a.plugin.util.WaitUntil] Plugins that have yet to be enabled: (1): [com.atlassian.upm.atlassian-universal-plugin-manager-selfupdate-plugin], 300 seconds remaining
2020-02-04 10:11:29,897+0100 ClusterMessageHandlerServiceThread:thread-1 INFO [c.a.plugin.loaders.ScanningPluginLoader] No plugins found to be installed

 

Could you help with this one ?

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you