UPM 2.7.3 and Jira 5.1.5 doesn't work

Hi,

I'm having a problem with the UPM and Jira. Please look at the screenshot attached. This happens with everything that I want to update. The plugin, however, does upgrade with no problems but I must stop my jira and start it again. What can I do to fix this?

Thanks,

Carlos

4 answers

1 accepted

Accepted Answer
0 votes

Unofficially, I'd test it out right away (of course during a maintenance period). If it's good for the goose, it's good for the gander.

Here is the screenshot.

Hi Carlitos,

I'd already seen this error. Generally it is related to:

1) Apache/IIS proxying connections to JIRA;
2) Incorrect baseURL configuration;
3) Incorrect SSL configuration.

Would you check this three points?

Another thing that it is not clear for me: Have you upgraded JIRA recently? Has UPM worked in previous JIRA versions?

Best regards,
Lucas Timm

Hi Lucas,

I recently upgraded both.

  • From Jira 5.0.6 to 5.1.5
  • From UPM 2.4.2 (I think) to 2.7.3

I haven't changed my base url. I am using Apache Virtual Hosts (to hide the ports from my Ubuntu Linux). Nevertheless, everything was working well before the upgrade. I also have Fisheye and Confluence in the same box. And those work perfectly. There seems to be an issue with UPM/Jira combination.

Not really sure where/what to look for.

Regards,

Carlitos

What does your Jira logs show you? It could be related to a plugin that needs to be updated as an another possibility.

I don't see anything related to the plugin. I tried the log scanner and I get these:

<th>Problem</th><th>Matches</th>
Quick Searching for Issues Fails 14 matches, last match on line 14172
Emails containing attachments with non-ASCII names lost 56 matches, last match on line 13215
JIRA Stops Creating Issues from Emails 5 matches, last match on line 11682
Workflow error: Cannot find Screen with id 'xxxxx' 1 match on line 8652
Hercules throws a java.util.regex.PatternSyntaxException when scanning the logs 2 matches, last match on line 5390
After upgrade to JIRA 5, Activity Stream or Gadgets no longer work 1 match on line 5373

I have to say that these are really old though and would consider them resolved.

I also updated all plugins but all of them seem to work. I did have to stop and start Jira for things to work though.

Regards,

Carlos

Carlos,

Please review this page:

https://confluence.atlassian.com/display/JIRA/Integrating+JIRA+with+Apache

Especially the line related to configuring the proxyname for your server.xml:

proxyName="your-front-facing-domain.com" proxyPort="80"

Hi John,

That did the trick! Thanks!!!

I wonder if I should do the same for Confluence and Fisheye. Though they are not presenting any issue after the upgrade. It was only Jira who was being a brat.

Carlos

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 18, 2018 in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

21,645 views 2 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you