Transition buttons do not respond to the workflow

Hello, I renamed some transitions and did some minor adjustments to a default workflow of my service desk and I expected the buttons in the issue "button bar" would adjust accordingly. I can see my new status names in the issue detail.

http://1drv.ms/1p6vC29

Am I missing something? Can anybody point me at a docu point where I can understand what do I do wrong?

6 answers

1 accepted

This widget could not be displayed.

This has not been resolved by Atlassian for a week so I quit experimenting. I faced some weird "index rebuilding" requirement which I was unable to perform.

Dunno how this is realted, but it does not matter now.

This widget could not be displayed.

This widget could not be displayed.

This widget could not be displayed.

Hi Jan,

Do the workflow buttons have the wrong button label or do they not show up at all?

They have wrong button label and generally do not follow the workflow I have defined.

My workflow is as captured on the screenshot above, while the button has following cycle: "Respond to customer" > "Ready to support" > "Respond to customer"

From what I read I believe those buttons should correspond available "transitions" in every given workflow step.

My workflow has following transitions defined. While the "workflow" switches correctly between "From" statuses, it still does display different transitions than what I have defined. I also added the "Ready for Support X" name to make sure the "Ready for Support" button I have is not from my workflow.

This is the workflow screenshot

Hi Jan,

Are you sure your workflow scheme is configured correctly and it links the correct issues to your workflow? Please also check if your workflow scheme is also added to the project correctly.

Also when you click the view workflow link in your issue detail view, do you see the correct workflow image?

yes I do see the correct workflow

This widget could not be displayed.

They have wrong button label and generally do not follow the workflow I have defined.

My workflow is as captured on the screenshot above, while the button has following cycle: "Respond to customer" > "Ready to support" > "Respond to customer"

From what I read I believe those buttons should correspond available "transitions" in every given workflow step.

My workflow has following transitions defined. While the "workflow" switches correctly between "From" statuses, it still does display different transitions than what I have defined. I also added the "Ready for Support X" name to make sure the "Ready for Support" button I have is not from my workflow.

This widget could not be displayed.

This worked for me. A pain but at least it worked.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

155 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you