Tempo: Resources Not showing up in Tempo Reports when we Deactivate/Delete from Active Directory

We need to deactivate employees from Active Directory immediately and then delete within 90 days. The problem is when we deactivate and then delete the accounts from Active Directory the users are no longer showing up in the Tempo reports. Is there a way to still show the history of data that is stored in JIRA (for time tracking in Tempo) even though their accounts are deactivated or deleted within Active Directory? Please advise.

3 answers

1 accepted

This widget could not be displayed.

Hi John

The worklogs for deleted users are displayed in the following places in Tempo

  • Project Report and Timesheet
  • Account Report and Timesheet
  • Invalid Worklogs Report and Timesheet
  • Advanced Worklogs Report and Timesheet

Deleted users are displayed with no avatar and the username in Initials and Full Name fields

Hope this helps
Sverrir Tynes
Tempo support

Sverrir, this does not seem to be the case for us. Is there any configuration settings to toggle to ensure we should see deleted users?

This may be true for DEACTIVATED AD users, but not DELETED ones, at least in our experience

This widget could not be displayed.

Hi John

If users are deleted in JIRA but have timetracking in tempo as they were members of Tempo team(s) when deleted are displayed in Tempo as mentioned earlier.

I don t think that there is a way to see deleted users in JIRA it sure is not in Tempo configuration.

This might be more complexed if your are using external user management in your JIRA instanse.

It appears that the question is not answered here - and I have the same question - we are seeing Tempo data disappear when a user is deleted from Active Directory. The deactivated JIRA user is placed in a "jira_inactive users" group and removed from jira-user. (similar to John's scenario). after 90 days we delete the user from AD  - and then all of the Tempo Data associated with them disappears. We need to retain the worklogs for reporting history. 

 

Any updates on this issue? We had suspended a business rule to delete users after 90 days, but now it is being revisited. 

This widget could not be displayed.

Hi Sverrir,


We see the same in the Team Timesheets; when a user is deactivated, it disappears from the timesheet(s).
For now; we have resolved this by removing a user from the jira-users group, but that's not the best solution i think. Should we raise an issue for this?

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

173 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you