Team In Space DEMO >>> Not able to login into JIRA/Confluence server <<<

Hi All,

I have installed "Team In Space" software on Ubuntu Linux x86_64 operation system with 8Gb of RAM following the Overview at link:
https://bitbucket.org/atlassian/teams-in-space-demo for Linux (Debian/Ubuntu) ...

Then I perform the tis-install and the tis-reset as mentioned in the link.

After that I tried logging in JIRA server, with user 'admin' and password as Charlie!, WITHOUT success.

Following the JIRA log message:

2017-07-21 11:49:09,282 http-nio-8080-exec-13 ERROR anonymous 709x87x1 ivesoz 192.168.XXX.YYY /rest/gadget/1.0/login [c.a.c.manager.application.ApplicationServiceGeneric] Directory 'Crowd Server' is not functional during authentication of 'admin'. Skipped.
21-Jul-2017 11:49:09.365 WARNING [http-nio-8080-exec-13] com.sun.jersey.spi.container.servlet.WebComponent.filterFormParameters A servlet request, to the URI http://jira.teamsinspace.com:8080/rest/gadget/1.0/login, contains form parameters in the request body but the request body has been consumed by the servlet or a servlet filter accessing the request parameters. Only resource methods using @FormParam will work as expected. Resource methods consuming the request body by other means will not work as expected.

The same behaviour occurs for Confluence login.

In attach could you find the the link of the tis-reset execution log tis-reset.log

Take in account that I try the login in Bamboo or Bitbucket WITH success.


Could you help me ?

Thanks in advance to all!

Francesco

2 answers

1 accepted

This widget could not be displayed.

I got this error in crowd log, using only crowd:

     Invalid SSO Domain value.: '.teamsinspace.com' .....

I think the real issue is configure TEAM IN SPACE using this domain, not present in own local environment. Without a specific configuration in /etc/hosts NONE can log in all products in TEAM IN SPACE. 

just create this entry in /etc/hosts:

127.0.0.1 crowd.teamsinspace.com 

and use this alias as URL. Now.... It works

OK.

Thanks.

Now it possible to login WITH success.

Thanks for this challange. :-)

I guess this solution works when you have a local installation of teams in space, but is not working when i install TIS on a VPS Server

Anyone could help me?

This widget could not be displayed.
Ann Worley Atlassian Team Jul 24, 2017

Please review this guide:  Crowd user authentication fails with 'Directory 'X' is not functional during authentication' error

There are 5 suggestions for why we might see that message in the log: 

Directory 'Crowd Server' is not functional during authentication of 'admin'. Skipped.

The guide also has instructions for elevated logging if we have to dig more deeply. 

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

148 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you