It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Tagging a user in comments shows ~accountID

When someone tags a person, it's showing as  "[~accountid:5c8fd07816653d2d0f0253ba] [~accountid:5b994a6e7c582d2b86e27a92] "

This only occurs to two users tagging others in the comments. When I do it myself, it shows the tagged users properly. 

I haven't been able to find anyone with the same issue in forums.

1 answer

1 accepted

1 vote
Answer accepted

Hi Kitty,

Welcome to Atlassian Community!
Due to GDPR, usernames are being removed from our products. It was first removed from site administration and now it's being applied to the rest of the instance.
Once you save the comment it will show their full name, but when @mention them, it will show their ID.
You can find more details about these changes in the documentation below:
- Say goodbye to usernames in Atlassian Cloud
- Changes to usernames in Jira Cloud

If you are using the old view on a classic project and the userid is showing after saving the comment, please check the field renderer by going to Project settings > Fields > Screenshot 2019-05-08_15-45-56.png > Comment > Screenshot 2019-05-08_15-46-41.png > Renderers > Wiki Style Renderer > Update.


Thanks! That fixed it.

Like # people like this

This is BROKEN. It happened a while ago then started working again, now it's back. AccountID's are NOT being replaced after save...


Hi Wayne,

Just to make sure we are on the same page, can you please let us know if this issue is happening on the new or old view?
If it's happening on the old view, you need to follow the steps of my previous answer to make sure the renderer of the field is Wiki Style and not text. 


I'm seeing it in the old view, and it resolves, but no issue in the new view.  

Cloud platform.

Does it take some time for the update to happen? Or is this instance.
After trying the suggested fix above to change the render = Wiki Style Renderer for the comment field configuration.
It does not appear to instantly resolve the issue.
Still seeing accountid following the name when initially typing in the "@" mention into the comment field. 

Hi Nilesh,

Thank you for reaching out to Community!

The change will only take effect when you post the comment with the mention. It's expected that when you select the user it shows the accountID, but once you post the comment it will show correctly.


Suggest an answer

Log in or Sign up to answer

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you