System plugin and installed plugin not working on jira 4.4.5

Hi ,

I have recently upgrade JIRA 3.13 to JIRA 4.4.5 ( which is required to move to JIRA 6).

I took the xml backup of prod data and created a Dev instance witj upgraded JIRA 4.4.5.

after upgrade all system plugins and installed plugins are not working.

I am not able to see any option to install, upgrade, disable plugins.

 

please suggest 

1 answer

0 vote

What does the log file say, from the startup of the new Jira?  Were there errors thrown into the log when you upgraded?

at com.sun.jersey.client.apache.ApacheHttpClientHandler.handle(ApacheHttpClientHandler.java:197)
... 142 more
2015-04-30 13:40:36,832 http-8080-1 ERROR tamraksa 816x124x1 1rgwkvn 10.219.170.226 /rest/plugins/1.0/upgrades [server.impl.application.WebApplicationImpl] Internal server error
com.sun.jersey.api.client.ClientHandlerException: java.net.ConnectException: Connection timed out
at com.sun.jersey.client.apache.ApacheHttpClientHandler.handle(ApacheHttpClientHandler.java:202)
at com.sun.jersey.api.client.Client.handle(Client.java:365)
at com.sun.jersey.api.client.WebResource.handle(WebResource.java:556)
at com.sun.jersey.api.client.WebResource.post(WebResource.java:226)

dint get any specific error in catalina during upgrade.

Ok, that's a start, but there are more errors in your log. Is this the first one? Are there more later on in the file?

___ Starting the JIRA Plugin System _________________ 2015-04-29 10:50:10,043 main INFO [atlassian.plugin.manager.DefaultPluginManager] Initialising the plugin system 2015-04-29 10:50:13,954 main INFO [atlassian.plugin.loaders.ScanningPluginLoader] Plugin Unit: /apps/JIRA/stage/SUZAKU_HOME/jira-home/plugins/.bundled-pl ugins/auiplugin-3.4.2.jar (1329332952000) created 2015-04-29 10:50:14,043 main INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.auiplugin], 60 seconds remaining 2015-04-29 10:50:15,049 main INFO [atlassian.plugin.loaders.ScanningPluginLoader] No plugins found to be deployed 2015-04-29 10:50:15,056 main INFO [atlassian.plugin.manager.DefaultPluginManager] Plugin system started in 0:00:05.010 ___ Plugin System Started _________________ 2015-04-29 10:52:21,287 http-8080-2 WARN anonymous 652x6x1 cup6h1 10.219.170.226 /secure/SetupDatabase.jspa [core.entity.jdbc.DatabaseUtil] Entity "PluginVers ion" has no table in the database 2015-04-29 10:52:22,133 http-8080-2 INFO anonymous 652x6x1 cup6h1 10.219.170.226 /secure/SetupDatabase.jspa [atlassian.plugin.manager.DefaultPluginManager] Sh utting down the plugin system ___ Starting the JIRA Plugin System _________________ 2015-04-29 10:52:24,134 http-8080-2 INFO anonymous 652x6x1 cup6h1 10.219.170.226 /secure/SetupDatabase.jspa [atlassian.plugin.manager.DefaultPluginManager] In itialising the plugin system

Your database is damaged. I suspect the upgrade process has failed, badly, and you'll need to go back to the last version that worked perfectly, then read the upgrade logs to find out where it went wrong.

this is my Dev instance. i have reinstalled jira 4.4.5 and still the same issue coming

started everything from scratch and it dint work

As we need to upgrade to 6.3.13...do you suggest we should move further and upgrade my Dev instance to6.3.13 and try to fix this error in latest version ?

You need to go back to the last *working* version you have and work back through an upgrade process, stopping when it goes wrong and analysing the reasons for failure. "it didn't work" is not an analysis, it tells us nothing of any use about what went wrong. What data is corrupted? What error messages do you get WHILE the upgrade is running? Was your server attacked by a flock of annoyed penguins while it was supposed to be upgrading? Are there file reading errors? PLEASE, don't try to jump too far. 3.13 to 6.3 is absolutely NOT recommended, you're just making things more complicated and hence worse. 3.13 to 4.4.5 is a sensible move and you need to have that working properly before you go further. Could you explain, in a few simple bullet points, the steps you took to create the 4.4.5 system? For example - installed a new empty 4.4.5 on a machine and got it working with no data - installed the plugins I might need on 4.4.5 - got xml export from 3.13 - ran the system import from xml in the 4.4.5 system ... and then tell us what the errors are in the logs. Not startup or restart, but the upgrade errors.

Hi Nic..find the steps i performed for 4.4.5 - Got a new linux RHEL 6.5 - downloaded 4.4.5 tar from atlassian site - created 2 folders 1 for jira installable 2nd for jira home - untar 4.4.5 in jira installable folder - arrangedand empty database - patched bin/setenv.sh: provide JAVA_HOME, JIRA_HOME -get atlassian-jira/WEB-INF/classes/osuser.xml from old prod instance and put it to atlassian-jira/WEB-INF/classes of 4.4.5 instance -ran the 4.4.5 instance with bin/start-jira.sh -went to http://hostname:8080 - on firstsetup page, provided eternal database details (new empty db) and imported XML backup; provided path to XML backup file and valid license; started import without any issue - Jira was properly upgraded without any error in front end. - was able to find all the issues/data which were restored from xml backup -But...while trying to create new issue, found following error "Error creating issue: Could not load FunctionProvider class" which was related to plugin installation - while looking for plugins, i found all the system plugins are listing but there no option comping after expanding to disable/enable them - tried to install user installed plugin from market but market was not being connected, so downloaded the plugin in my machine and tried to installed. - plugin is listing now but no options to enable/disable/upgrade. ____________________________________________________________________ find screen shot from catalina.out ___ Starting the JIRA Plugin System _________________ 2015-05-04 08:08:14,456 main INFO [atlassian.plugin.manager.DefaultPluginManager] Initialising the plugin system 2015-05-04 08:08:18,399 main INFO [atlassian.plugin.loaders.ScanningPluginLoader] Plugin Unit: /apps/JIRA/stage/SUZAKU_HOME/jira-home/plugins/.bundled-pl ugins/auiplugin-3.4.2.jar (1329332952000) created 2015-05-04 08:08:18,460 main INFO [atlassian.plugin.util.WaitUntil] Plugins that have yet to be enabled: [com.atlassian.auiplugin], 59 seconds remaining 2015-05-04 08:08:19,469 main INFO [atlassian.plugin.loaders.ScanningPluginLoader] No plugins found to be deployed 2015-05-04 08:08:19,474 main INFO [atlassian.plugin.manager.DefaultPluginManager] Plugin system started in 0:00:05.016 2015-05-04 08:08:19,475 main INFO [atlassian.jira.startup.JiraStartupLogger] ___ Plugin System Started _________________ 2015-05-04 08:08:19,966 main INFO [jira.config.database.DatabaseConfigurationManagerImpl] The database is not yet configured 2015-05-04 08:08:19,967 main INFO [jira.config.database.DatabaseConfigurationManagerImpl] Enqueuing Database Checklist Launcher' on post-database-configu red-but-pre-database-activated queue 2015-05-04 08:08:19,967 main INFO [jira.config.database.DatabaseConfigurationManagerImpl] The database is not yet configured 2015-05-04 08:08:19,967 main INFO [jira.config.database.DatabaseConfigurationManagerImpl] Enqueuing Post database-configuration launchers' on post-databa se-activated queue at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) 2015-05-04 09:39:35,304 http-8080-12 ERROR tamraksa 575x1929x3 1xsae4t 10.219.170.226 /rest/plugins/1.0/available/featured [server.impl.application.WebApplica tionImpl] Internal server error at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) 2015-05-04 09:43:05,413 IssueIndexer:thread-1 ERROR tamraksa 583x2851x3 1xsae4t 10.219.170.226 /secure/admin/jira/IndexReIndex.jspa [jira.issue.managers.Defau ltCustomFieldManager] Could not load custom field type plugin with key 'de.phil.jira.plugin:searchableattachment'. Is the plugin present and enabled? 2015-05-04 09:43:05,427 IssueIndexer:thread-1 ERROR tamraksa 583x2851x3 1xsae4t 10.219.170.226 /secure/admin/jira/IndexReIndex.jspa [jira.issue.managers.Defau ltCustomFieldManager] Could not load custom field type plugin with key 'com.atlassian.jira.toolkit:message'. Is the plugin present and enabled? 2015-05-04 09:43:05,427 IssueIndexer:thread-1 ERROR tamraksa 583x2851x3 1xsae4t 10.219.170.226 /secure/admin/jira/IndexReIndex.jspa [jira.issue.managers.Defau ltCustomFieldManager] Could not load custom field type plugin with key 'com.atlassian.jira.toolkit:message'. Is the plugin present and enabled? 2015-05-04 09:43:05,428 IssueIndexer:thread-1 ERROR tamraksa 583x2851x3 1xsae4t 10.219.170.226 /secure/admin/jira/IndexReIndex.jspa [jira.issue.managers.Defau ltCustomFieldManager] Could not load custom field type plugin with key 'com.atlassian.jira.toolkit:viewmessage'. Is the plugin present and enabled? 2015-05-04 09:43:05,428 IssueIndexer:thread-1 ERROR tamraksa 583x2851x3 1xsae4t 10.219.170.226 /secure/admin/jira/IndexReIndex.jspa [jira.issue.managers.Defau ltCustomFieldManager] Could not load custom field type plugin with key 'com.atlassian.jira.toolkit:viewmessage'. Is the plugin present and enabled? 2015-05-04 09:43:05,428 IssueIndexer:thread-1 ERROR tamraksa 583x2851x3 1xsae4t 10.219.170.226 /secure/admin/jira/IndexReIndex.jspa [jira.issue.managers.Defau ltCustomFieldManager] Could not load custom field type plugin with key 'com.atlassian.jira.toolkit:viewmessage'. Is the plugin present and enabled? 2015-05-04 09:43:05,428 IssueIndexer:thread-1 ERROR tamraksa 583x2851x3 1xsae4t 10.219.170.226 /secure/admin/jira/IndexReIndex.jspa [jira.issue.managers.Defau ltCustomFieldManager] Could not load custom field type plugin with key 'com.atlassian.jira.toolkit:viewmessage'. Is the plugin present and enabled? 2015-05-04 09:43:05,428 IssueIndexer:thread-1 ERROR tamraksa 583x2851x3 1xsae4t 10.219.170.226 /secure/admin/jira/IndexReIndex.jspa [jira.issue.managers.Defau ltCustomFieldManager] Could not load custom field type plugin with key 'com.atlassian.jira.toolkit:viewmessage'. Is the plugin present and enabled? 2015-05-04 09:43:05,428 IssueIndexer:thread-1 ERROR tamraksa 583x2851x3 1xsae4t 10.219.170.226 /secure/admin/jira/IndexReIndex.jspa [jira.issue.managers.Defau ltCustomFieldManager] Could not load custom field type plugin with key 'com.atlassian.jira.toolkit:viewmessage'. Is the plugin present and enabled? 2015-05-04 09:43:05,428 IssueIndexer:thread-1 ERROR tamraksa 583x2851x3 1xsae4t 10.219.170.226 /secure/admin/jira/IndexReIndex.jspa [jira.issue.managers.Defau ltCustomFieldManager] Could not load custom field type plugin with key 'com.atlassian.jira.toolkit:velocitymessage'. Is the plugin present and enabled? 2015-05-04 09:43:05,428 IssueIndexer:thread-1 ERROR tamraksa 583x2851x3 1xsae4t 10.219.170.226 /secure/admin/jira/IndexReIndex.jspa [jira.issue.managers.Defau ltCustomFieldManager] Could not load custom field type plugin with key 'com.atlassian.jira.toolkit:lastupdaterorcommenter'. Is the plugin present and enabled? 2015-05-04 09:43:05,429 IssueIndexer:thread-1 ERROR tamraksa 583x2851x3 1xsae4t 10.219.170.226 /secure/admin/jira/IndexReIndex.jspa [jira.issue.managers.Defau ltCustomFieldManager] Could not load custom field type plugin with key 'com.atlassian.jira.toolkit:lastupdaterorcommenter'. Is the plugin present and enabled? 2015-05-04 09:43:05,429 IssueIndexer:thread-1 ERROR tamraksa 583x2851x3 1xsae4t 10.219.170.226 /secure/admin/jira/IndexReIndex.jspa [jira.issue.managers.Defau ltCustomFieldManag at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) 2015-05-04 11:14:06,983 http-8080-15 ERROR tamraksa 674x6797x2 1xsae4t 10.219.170.226 /secure/CreateIssueDetails.jspa [atlassian.jira.workflow.DefaultOSWorkfl owConfigurator] Could not load class 'com.atlassian.jira.plugin.workflow.function.UpdateIssueCustomFieldPostFunction' Is that sufficient Nic or you want any other details. - And you have said that database has been currpted. I have flushed all the data from new db and re-initiated all the step from scratch.

Your installation has been done incorrectly, as there's chunks of it missing. That's probably leading to database errors later on. Again, could you go back to the upgrade logs and check them for errors. Also, you should check the startup log from the original installation of 4.4.5. You don't tell us what type of installation it is either, so we're a bit stuck on what exactly you have installed. Standalone or WAR?

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Monday in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

578 views 6 12
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you