It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

System Dashboard only works for user with administrator access

I have two users who when they log in, the system dashboard is blank and none of the drop downs for Issues, Boards, Dashboards, etc work.  They are simply blank.  The users are able to access the projects and issues directly via a saved URL.  And, they can navigate around after that.  It only happens when they access the System Dashboard page.

I gave one of the users administrator privileges and they could then access the System Dashboard and everything worked.  While in there I had them go to Manage Dashboards and Restore Defaults.  But, when I removed the administrator role from their account the issue returned.

One of the users captured a javascript error when they access the System Dashboard:

Uncaught SyntaxError: Unexpected identifier

batch.js?locale=en-US&spectrum=true:340 [Deprecation] document.registerElement is deprecated and will be removed in M80, around February 2020. Please use window.customElements.define instead. See https://www.chromestatus.com/features/4642138092470272 and https://developers.google.com/web/updates/2019/07/web-components-time-to-upgrade for more details.

f @ batch.js?locale=en-US&spectrum=true:340

batch.js:157 Uncaught TypeError: Cannot read property 'dateFormats' of undefined

    at batch.js:157

    at l (batch.js:25)

    at u (batch.js:25)

    at l (batch.js:25)

    at u (batch.js:25)

    at s (batch.js:25)

    at window.require (batch.js:28)

    at batch.js:163

    at batch.js:163

jira.webresources:calendar-en.js:15 Uncaught ReferenceError: Calendar is not defined

    at jira.webresources:calendar-en.js:15

batch.js:25 Uncaught Error: No jira/libs/calendar

    at u (batch.js:25)

    at s (batch.js:25)

    at batch.js:25

    at jira.webresources:calendar-localisation-moment.js:3

    at l (batch.js:25)

    at u (batch.js:25)

    at s (batch.js:25)

    at window.require (batch.js:28)

    at jira.webresources:calendar-localisation-moment.js:3

undefined/rest/webResources/1.0/resources:1 Failed to load resource: the server responded with a status of 404 ()

batch.js:249 DEPRECATED JS - Dropdown constructor has been deprecated and will be removed in a future release. Use Dropdown2 instead.  

     at HTMLDocument.<anonymous> (https://jira.tnc.org/s/25faa3ea703da71e3468c24b4d775f09-CDN/qhg8ou/713009/6411e0087192541a09d88223fb51a6a0/a248d7e5de4dcf1c45e4cb960b068569/_/download/contextbatch/js/_super/batch.js?locale=en-US&spectrum=true:3912:201)

k @ batch.js:249

undefined/rest/helptips/1.0/tips?_=1578396693889:1 Failed to load resource: the server responded with a status of 404 ()

 

5 answers

1 accepted

2 votes
Answer accepted

I was able to resolve my issue.  Here's the short answer.  I installed the 5.6.11 patch for ScriptRunner.  Hopefully this works for you all as well.

Here's how I got there.  I finally I started reading through the jira logs (hindsight - I should have looked sooner).  I found this message.

2020-01-08 18:14:27,640 http-nio-8080-exec-12 ERROR <user experiencing the issue> 1094x3867x1 of17zj <ip addresses> /secure/Dashboard.jspa [c.a.p.webresource.data.DataTagWriter] Exception encountered rendering data resource '[com.onresolve.jira.groovy.groovyrunner:directIdeaIntegration.idea-editor-data-provider]'

com.atlassian.cache.CacheException: java.lang.NullPointerException: Cannot get property 'codeEditPermissionsEnabled' on null object

That put me on Scriptrunner as the culprit.  I disabled Scriptrunner and then enabled and the issue went away  But, the original issue seemed be triggered by restarting the jira server  - that's when users first reported it - so I tried restarting the server and yes in fact the issue came back.  So then I kept trying other things like clearing the Scriptrunner cache and jira cache, disabling Scriptrunner modules, enabling Scriptrunner modules, rebuilding the system dashboard again.  Then, I noticed there was an update to ScriptRunner (it came today I think).  Thought, what the heck. I installed it and it worked.  Issue does not come back after a restart.

I think it is related, somehow, to this resolved bug in the patch.  The work around described is similar to what I found that worked- disable and enable Scriptrunner.

https://productsupport.adaptavist.com/browse/SRPLAT-873?_ga=2.10395381.1536105730.1578590066-558765450.1578501638

thanks @Dean Hill 

i updated scriptrunner and it works fine now

Confirmed here too. Dashbords came back after I ugraded scriptrunner, but I also finished off a complete cache clear out at the same time. Seems likely that scriptrunner was the culprit though.

saved my day! :-D

We had a very similar issue after a Jira restart.

After changing the "System Dashboard" layout once, all seams to be back to normal.
- Jira settings > System
- User interface section - click System dashboard

Thank you for the suggestion.  This did not fix the issue however.

You were right about one thing though - shortly after a restart, users started experiencing the issue.

I tried completely rebuilding the system dashboard.  Tried a system dashboard with no gadgets.  Tried different layouts using the Edit Layout button.  Nothing made a difference.  Any other thoughts?

i have exactly the same problem two days ago, and try @José Pequeno 's suggestion but it does not work.

i've tried everything with dashboard just like rebuilding it... and even i tried to restore the whole database to the old database exported several days before the error, tried clearing all kind of caches and plugin caches but it still blank dashboard for non-admin user.

it's quite weird because:

- if it's problem/ error with the codes, then all users would have to face this problem. but here, dashboard works fine with admin user, but for non-admin user it's blank page with lots of js error while viewing source code

- if it's error in database, then restoring db to the old one befor the error would solve the problem. but even when i do db restoring, the problem is still there.

anyone with thoughts and solutions to this?

thank you.

We have an even trickier issue... We are testing a conversion from Windows to Linux and ar experiencing all of the above EXCEPT - I gave the user admin access and she still has the issue. If I log in as her using the Built in script in ScriptRunner, I experience the issue no matter what permissions she has. 

Tried this on another user with same results. 

However, I and other users who had jira-admin or jira-project-admin permission do not have the issue. 

We cannot find anything on the system dashboard that would be blocked from jira-user access... completely stumped. 

resolved - the plug in update worked

We have the same issue. Seems that URL for "resources" and "tips" are failing with 404, adding /undefined/ in the URLS

Use the inspect function in browser, network tab,  to check if you guys see the same. For the admin users the "tips" URL is not requested at all.

2020-01-09_09-16-39-2.jpg

I had the same issue in our instance, It was reported by one user.  Was able to use the workaround - Disable/Enable Scriptrunner plugin successfully.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you