Subtasks are not getting resolved when "done"

Hello,

I currently have the following issue:

  • created a task, of type "new feature"
  • added a list of sub-tasks
  • when sub-tasks were finished, set them to "Done"

In the beginning, all went well: the sub-tasks where "Done", and their Resolution set to "Resolved". So I had the "green tick" feedback, and I could filter them out as being not opened.

But at some point (don't know why), setting the sub-tasks to "Done" did not change the Resolution. So they where still Unresolved, Opened, and now I have a lot of tickets still opened and it's quite annoying as the open issues filters are "spammed" with supposedely closed tickets.

I tried lots of things: re-opened them, started progress, stopped progress, set them to "done" with/without starting progress, I tried a lot of different patterns but to no avail.

Anyone can help me?

Thank you.

3 answers

Is done a status in JIRA or the column in Greenhopper / JIRA Agile? Usually, if you don't set the resolution yourself, it's being done by a post-function.

Use case: You had the closed status mapped to the Done column. Transitions leading to the closed status had the post-function. Now the XYZ status is mapped to that column but the transitions to that status don't have any post-functions...--> no resolution. Either way, check the transitions and the post-functions in your workflow...

Cheers

Christian

0 vote
Joe Wai Tye Atlassian Team Sep 10, 2013

Hi Vincent,

Hmm, you might want to check if there have been any recent changes towards the workflow for your Sub-task issue type (if you have one). Currently my main suspicion would be that the transition into the "Done" status has been edited such that the resolution of the issue would no longer be set.

This is usually configured in the post-functions of the transition.

I'm having the same problem. I'm an admin on our account.

I found the "Permission Helper" in the administration section, but it says I *have* permission to 'resolve' an issue.

I have tried updating the workflow to a differnet type (reused and existing one for a sub-task).

I found under Admin | issues | resolution:

Done GreenHopper Managed Resolution

I'm stumped.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

246 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you