I started trying to run JIRA on a small VPS (512mb of ram SSD drive 2 core Processor) after running into a lot of brick walls and taking forever to get any kind of error page (and every once in awhile seeing the setup page in my browser) I shut down my VPS and upgraded to a 1Gb of ram, and 4 cores. Now I get faster issues (with database now) It says I got the wrong information (which I configured via command line) I was wondering is their any way I can just flush out all the configs and get back to that install screen in my browser? My problem I believe was I created the database incorrectly following another guide then I found this guide https://confluence.atlassian.com/display/JIRA/Connecting+JIRA+to+MySQLand I have it working fine on a local system now... But I need my 4 members to be able to access a server on the internet.

2 answers

1 accepted

2 votes

Stop Jira, drop all the tables in the database, remove the contents of your Jira home directory (move rather than delete, just to be on the safe side) and restart Jira.

If, however, it really is just the database, then I'd stop Jira, create a new database for it, then hack the dbconfig.xml file in jira home to point to the new one, restarting it should create everything clean.

BUT, before you do any of that, the problem you're getting is just that Jira can't log into the existing database - did you re-grant all the right permissions in the database after you altered it?

What I first did was logged into mysql, create database jira; and then I granted all permissions and flushed. I then ran the config.sh and told it to use mysql, gave all the details and then I ran into the error above. I then found the guide on making a mysql database which had me set the type UTF-set 8 (going off memory here) so i dropped the first database and created a brand new database... I've never used JIRA before nor have I ever ran any java apps before.

I edited the dbconfig.xml like you suggested and reloaded the site and Now I get a brand new error.

The following plugins are required by JIRA, but have not been started:

  • Gadget Directory Plugin (com.atlassian.gadgets.directory)

In my instance addinh -Datlassian.plugins.enable.wait=300 to JVM_EXTRA_ARGS in /opt/atlassian/jira/bin/setenv.sh fixed it.

Ahh excellent. Sometimes a clean database is the most simple option.

HTTP Status 500 - org.ofbiz.core.util.GeneralRuntimeException: Could not determine database type. (Access denied for user '****'@'***' (using password: YES))

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

188 views 1 17
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you