Sprint Health Check Gadget Missing

We just upgraded from Jira 5.2.11 and Greenhopper 6.2.5 to Jira 6.1.7 and Jira Agile 6.3.7. After the upgrade all of the Jira Agile gadget appears to be missing (specifically the Health Check Gaget). I assume the name changed from GreenHopper Sprint Health Gadget to Jira Agile Spring Health Gadget (or something to that effect) but I can't it anywhere. The Jira Agile plug-in is enabled, has an active licence, and all the modules are enabled. The rest of Jira Agile appears to be working fine. What am I missing?

5 answers

1 accepted

0 votes
Accepted answer
Ruchi Tandon Atlassian Team Apr 02, 2014

Run these queries in the database :

INSERT INTO propertyentry 
VALUES      ((SELECT seq_id 
              FROM   sequence_value_item 
              WHERE  seq_name = 'OSPropertyEntry'), 
             'GreenHopper.properties', 
             1, 
             'GreenHopper.JIRA60.Version.Migration', 
             1); 

INSERT INTO propertynumber 
VALUES      ((SELECT seq_id 
              FROM   sequence_value_item 
              WHERE  seq_name = 'OSPropertyEntry'), 
             1); 

UPDATE sequence_value_item 
SET    seq_id = (SELECT seq_id 
                 FROM   sequence_value_item 
                 WHERE  seq_name = 'OSPropertyEntry') 
                + 10 
WHERE  seq_name = 'OSPropertyEntry';

That should fix the error.

*Do not forget to make a copy of your database before running any quueries.*

0 votes

Yep it changes its name to Agile Sprint Health Check gadget. Try to re-index and see if that works, if not you may want to create a ticket in support.atlassian.com

No such gadget exists and I've tried re-index. Reviewing my upgrade process, it appears that I did not disable the previous Greenhopper plug-in (6.2.5 which was not compatible with Jira 6.1.7) prior to upgrading Jira. This is on our sandbox installation, so I'll refresh back to the original state and try the upgrade process again (this time disabling Greenhopper prior to Jira upgrade, update Jira, re-index, update the plug-in, re-enable the plug-in and then re-index again). If it still doesn't work, I'll submit a ticket. Thanks for your suggestion.

Hello Jason,

I have the same issue here, did you find out how to solve this?

Thanks

No, not directly. Since the was done on our pre-production installaiton we rolled back the installaiton and database back to it's original state (refreshed from our prod installation). Then we upgraded Jira Agile to 6.3.6.1 which was compatible with both Jira 5.2.11 and Jira 6.1.7. We didn't enoucnter the problem after that (although we haven't performed the Jira 5.2.11 to 6.1.7 upgrade yet).

I created a support ticket for this, when they find a solution I will post it here.

Regards

Jason,

The support pointed me to this bug https://jira.atlassian.com/browse/GHS-9991, wich is not resolved yet, but it has a workaround that worked for me.

Best Regards,

Luiz Papa

When upgrading again to Jira 6.1.7 again, encountered the same issue. Ran the database script listed in the bug (GHS-9991) description (the one Ruchi provided as an answer to this question) and it solved the problem. The bug lists the cause as being related to having a large number of fixVersions (>5K) although our installation has right around 1000. So it seems that there are more causes of this issue than just the large number of fixVersions.

Have the same problem. Can't find any JIRA Agile gadgets.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,419 views 15 19
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you