Sorry, we had some technical problems during your last operation error while publishing the workflow

Megha P May 10, 2021

Hi Team,

 

We are using Jira server. If we edit the workflow, we can not able to publish the workflow. getting below error  

"Sorry, we had some technical problems during your last operation error while publishing the workflow,

Technical details
Log's referral number: 9210da2d-67fd-443d-9230-b75b523c1910

Cause
Referer URL: https://rtrackconnect.ramco.com/secure/admin/workflows/ViewWorkflowSteps.jspa?workflowMode=draft&workflowName=INIM+Workflow&project=26101

com.atlassian.jira.exception.DataAccessException: org.ofbiz.core.entity.GenericEntityException: while updating: [GenericEntity:Workflow][creator,null][name,INIM Workflow][islocked,null][id,17940][descriptor,<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE workflow PUBLIC "-//OpenSymphony Group//DTD OSWorkflow 2.8//EN" "http://www.opensymphony.com/osworkflow/workflow_2_8.dtd">
<workflow>
  <meta name="jira.description"></meta>
  <meta name="jira.update.author.key">mani428</meta>
  <meta name="jira.updated.date">1620144590061</meta> 
  <initial-actions>
    <action id="1" name="Create">
      <validators>
        <validator name="" type="class">
          <arg name="permission">Create Issue</arg>
          <arg name="class.name">com.atlassian.jira.workflow.validator.PermissionValidator</arg>
        </validator>
      </validators>
      <results>
        <unconditional-result old-status="null" status="open" step="1">
          <post-functions>
            <function type="class">
              <arg name="class.name">com.atlassian.jira.workflow.function.issue.IssueCreateFunction</arg>
            </function>
            <function type="class">
              <arg name="full.module.key">com.atlassian.jira.plugin.system.workflowupdateissuestatus-function</arg>
              <arg name="class.name">com.atlassian.jira.workflow.function.issue.UpdateIssueStatusFunction</arg>
            </function>
            <function type="class">
              <arg name="class.name">com.atlassian.jira.workflow.function.issue.IssueReindexFunction</arg>
            </function>
            <function type="class">
              <arg name="field.name">customfield_19162</arg>
              <arg name="full.module.key">com.googlecode.jira-suite-utilitiesupdateIssueCustomField-function</arg>
              <arg name="field.value">Pending</arg>
              <arg name="class.name">com.googlecode.jsu.workflow.function.UpdateIssueCustomFieldPostFunction</arg>
            </function>
            <function type="class">
              <arg name="eventTypeId">1</arg>
              <arg name="class.name">com.atlassian.jira.workflow.function.event.FireIssueEventFunction</arg>
            </function>
            <function type="class">
              <arg name="toUsersInField"></arg>
              <arg name="addToAsWatchers">false</arg>
              <arg name="attachments">none</arg>
              <arg name="emailBody">&lt;!DOCTYPE&gt;
&lt;html&gt;  
&lt;head&gt;
&lt;style&gt; 

table, th, td {  
    border: 1px solid black;  
    border-radius: 25px;
    width: 555px;
    padding: 35px;

    
 
}  
th, td {  
   border-radius: 12px;
    padding: 15px;  
}  
table#alter tr:nth-child(even) {
    border-radius: 12px;
    padding: 15px; 
    background-color:  #33d6ff;  
}  
table#alter tr:nth-child(odd) { 
    border-radius: 12px;
    padding: 15px;

    background-color: #99ebff;  
}  
table#alter th {  
    color: white;  
    background-color: #0099ff;  
}  

Kindly help to resolve this issue

 

2 answers

0 votes
Andy Heinzer
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
May 11, 2021

This error message appears to be truncated before we can see exactly what the cause is.  I would be interested to see if you can recreate this problem, and then immediately investigate in the $JIRAHOME/log/atlassian-jira.log file.  I would expect that you will see a more comprehensive stack trace that should tell us more about why this workflow is not being saved.

I came across a similar support case that threw a similar error. In that other case, they were using a Microsoft SQL database for the Jira database, and it appears that there was a limitation in regards to max size of a text field.  We have a related KB for that situation for Confluence Server over in Unable to upgrade plugins due to Length of LOB data in SQL server.  I'm not sure if that specific problem affects you here, but this kind of error feels like some kind of database error or limitation.  Perhaps a more complete stack trace can give us more clues about this problem.

Andy

0 votes
Tuncay Senturk
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
May 10, 2021

Hello @Megha P 

Have you run Integrity Checker? 

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