Some attachments not found after migration

I've migrated from 3.x to the latest JIRA version. When copying over attachments there was a network error, so only half of the attachments were copied. All those attachments show perfectly fine.

I then copied over the missed attachments and reindexed - unfortunately the attachments don't show. The links are still there but when I click one, I get a 404 and the message that the attachment wasn't found:

Attachment /13339/screenshot.jpg was not found

Could not find what you were looking for. Maybe you should raise an issue.

JIRA home

So (background) reindexing doesn't work. I can't lock JIRA to do the other indexing, but that doesn't make a difference anyway, does it?

What can I do to get the attachments reattached?

Thanks

5 answers

1 accepted

This widget could not be displayed.

Redid the whole lot and it worked...

This widget could not be displayed.

Hi Elbe,

In fact, during this process, you migrated to a 4.x version before the latest one, correct? In JIRA 4.4.x, the attachments name changed, that's why the new instance can't recognize the files from your 3.x.

I can see two options here:

  1. Check the file name in your directory and the filename that JIRA is looking for. If it's something like 123456_screenshot.jpg in the directory and 123456.jpg in the instance, just change the file in your directory and see how it goes. That's because now JIRA is using an ID in the filename instead the ID plus a char name.
  2. The other option would be perform this migration again, but now with all the attachment files. So you will make sure that all attachments will work properly in the new instance.

Hope that helps.

Cheers,

This widget could not be displayed.

It's getting stranger now - after a full re-index, I can now access the screenshots. BUT: only the thumbnails are showing, even if I click it, the lightbox shows the thumbnail!

This widget could not be displayed.

Have you solved this?

This widget could not be displayed.

What if you are migrating from the same version of JIRA, just to a differfent server? How do we get the attchments to transfer over without having to perform this task manually?

Thanks!

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

172 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you