Setting up jira on Windows 2008 R2

Hi Guys,

I'm fairly new to the world of jira and have relatively little experience with Tomcat etc. I have a windows 2008 R2 virtual server box, which I want to run jira on over port 80. The server has two ip addresses assigned one of which I want to use for jira.

  1. I set up the DNS of the domain name I want to use to point to this IP address, and waited for it to resolve over the internet.
  2. I uninstalled IIS (at some point in the future I need IIS back on the box, at which point I will get it to bind to the other ip address)
  3. I stopped the web deployment agent service (which I belive binds to port 80)
  4. I stopped windows firewall (at some point this needs to be switched back on) by issuing:
    netsh advfirewall set AllProfiles state off
  5. In installed jira as a windows service with a SQL Server database, and modified the server.xml as follows:
    <?xml version="1.0" encoding="utf-8"?>
    <!--
       ====================================================================================
    
       Atlassian JIRA Standalone Edition Tomcat Configuration.
    
    
       See the following for more information
    
       http://confluence.atlassian.com/display/JIRA/Configuring+JIRA+Standalone
    
       ====================================================================================
     -->
    <!--
      Licensed to the Apache Software Foundation (ASF) under one or more
      contributor license agreements.  See the NOTICE file distributed with
      this work for additional information regarding copyright ownership.
      The ASF licenses this file to You under the Apache License, Version 2.0
      (the "License"); you may not use this file except in compliance with
      the License.  You may obtain a copy of the License at
    
          http://www.apache.org/licenses/LICENSE-2.0
    
      Unless required by applicable law or agreed to in writing, software
      distributed under the License is distributed on an "AS IS" BASIS,
      WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
      See the License for the specific language governing permissions and
      limitations under the License.
    -->
    <Server port="8005" shutdown="SHUTDOWN">
    
        <!--APR library loader. Documentation at /docs/apr.html -->
        <Listener className="org.apache.catalina.core.AprLifecycleListener" SSLEngine="on"/>
        <!--Initialize Jasper prior to webapps are loaded. Documentation at /docs/jasper-howto.html -->
        <Listener className="org.apache.catalina.core.JasperListener"/>
        <Listener className="org.apache.catalina.mbeans.GlobalResourcesLifecycleListener"/>
    
        <!-- Global JNDI resources
             Documentation at /docs/jndi-resources-howto.html
        -->
    
        <!-- A "Service" is a collection of one or more "Connectors" that share
            a single "Container" Note:  A "Service" is not itself a "Container",
            so you may not define subcomponents such as "Valves" at this level.
            Documentation at /docs/config/service.html
        -->
        <Service name="Catalina">
    
            <Connector port="80"
    
                       maxThreads="150"
                       minSpareThreads="25"
                       connectionTimeout="20000"
                       address="192.30.160.176"
                       enableLookups="false"
                       maxHttpHeaderSize="8192"
                       protocol="HTTP/1.1"
                       useBodyEncodingForURI="true"
                       redirectPort="8443"
                       acceptCount="100"
                       disableUploadTimeout="true"/>
    
            <!--
            ====================================================================================
    
            To run JIRA via HTTPS:
    
                 * Uncomment the Connector below
                 * Execute:
                     %JAVA_HOME%\bin\keytool -genkey -alias tomcat -keyalg RSA (Windows)
                     $JAVA_HOME/bin/keytool -genkey -alias tomcat -keyalg RSA  (Unix)
                   with a password value of "changeit" for both the certificate and the keystore itself.
                 * If you are on JDK1.3 or earlier, download and install JSSE 1.0.2 or later, and put the JAR files into
                   "$JAVA_HOME/jre/lib/ext"
                 * Restart and visit https://localhost:8443/
    
                 For more info, see :
    
                  http://confluence.atlassian.com/display/JIRA/Running+JIRA+over+SSL+or+HTTPS
    
                  and
    
                  http://tomcat.apache.org/tomcat-6.0-doc/ssl-howto.html
    
            ====================================================================================
            -->
            <!--
                <Connector port="8443" protocol="org.apache.coyote.http11.Http11Protocol"
                  maxHttpHeaderSize="8192" SSLEnabled="true"
                  maxThreads="150" minSpareThreads="25"
                  enableLookups="false" disableUploadTimeout="true"
                  acceptCount="100" scheme="https" secure="true"
                  clientAuth="false" sslProtocol="TLS" useBodyEncodingForURI="true"/>
            -->
    
    
            <!--
             ====================================================================================
    
             If you have Apache AJP Connector (mod_ajp) as a proxy in front of JIRA you should uncomment the following connector configuration line
    
             See the following for more information :
    
                http://confluence.atlassian.com/display/JIRA/Configuring+Apache+Reverse+Proxy+Using+the+AJP+Protocol
    
             ====================================================================================
            -->
    
            <!--
                  <Connector port="8009" redirectPort="8443" enableLookups="false" protocol="AJP/1.3" URIEncoding="UTF-8"/>
            -->
    
            <Engine name="Catalina" defaultHost="jira.xxxxxx.com">
                <Host name="jira.xxxxxx.com" appBase="webapps" unpackWARs="true" autoDeploy="true">
    <Context path="" docBase="${catalina.home}/atlassian-jira" reloadable="false" useHttpOnly="true"> <!-- ==================================================================================== Note, you no longer configure your database driver or connection parameters here. These are configured through the UI during application setup. ==================================================================================== --> <Resource name="UserTransaction" auth="Container" type="javax.transaction.UserTransaction" factory="org.objectweb.jotm.UserTransactionFactory" jotm.timeout="60"/> <Manager pathname=""/> </Context> </Host> <!-- ==================================================================================== Access Logging. This should produce access_log.<date> files in the 'logs' directory. The output access log lies has the following fields : IP Request_Id User Timestamp "HTTP_Method URL Protocol_Version" HTTP_Status_Code ResponseSize_in_Bytes RequestTime_In_Millis Referer User_Agent ASESSIONID eg : 192.168.3.238 1243466536012x12x1 admin [28/May/2009:09:22:17 +1000] "GET /jira/secure/admin/jira/IndexProgress.jspa?taskId=1 HTTP/1.1" 200 24267 1070 "http://carltondraught.sydney.atlassian.com:8090/jira/secure/admin/jira/IndexAdmin.jspa" "Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.10) Gecko/2009042523 Ubuntu/9.04 (jaunty) Firefox/3.0.10" "C2C99B632EE0F41E90F8EF7A201F6A78" NOTES: The RequestId is a millis_since_epoch plus request number plus number of concurrent users The Request time is in milliseconds The ASESSIONID is an hash of the JSESSIONID and hence is safe to publish within logs. A session cannot be reconstructed from it. See http://tomcat.apache.org/tomcat-6.0-doc/config/valve.html for more information on Tomcat Access Log Valves ==================================================================================== --> <Valve className="org.apache.catalina.valves.AccessLogValve" resolveHosts="false" pattern="%a %{jira.request.id}r %{jira.request.username}r %t &quot;%m %U%q %H&quot; %s %b %D &quot;%{Referer}i&quot; &quot;%{User-Agent}i&quot; &quot;%{jira.request.assession.id}r&quot;"/> </Engine> </Service> </Server>
    
    
    
    
    When I start the service I can access the jira.xxxxxx.com url on the server itself, but trying to access it externally does not work. What I am missing here?
    Any help would be much apprecaited.
    Many thanks,
    James.

9 answers

0 vote
Timothy Chin Community Champion Feb 25, 2013

And you try to resolve the domain name externally, does it return a proper result?

Yes, if you mean by pinging?

Wouldn't the fact that jira works locally with the domain name proove that it is resolving? The DNS for this domain is not on this server.

Can you tell me if my server.xml is set up correctly?

0 vote
Joseph Clark Atlassian Team Feb 25, 2013

address="192.30.160.176"

^ Is this the local IP address of the interface on the server that you want Tomcat to bind to when listening?

Yes that's the IP address
0 vote
Joseph Clark Atlassian Team Feb 25, 2013

Ah, well I guess that rules out the obvious problems :-)

Can you provide more description on how it does not work? Do you know what kind of error page you are seeing? It might help identify the cause.

When I browse to the URL from an external site, the browser spins for a while and then (IE for example) says cannot display the web page. However if I use the same URL internally it works fine.

I have also tried using (configuring jira to use) the IP address instead of the DNS name, and have also tried a multitutde of ports all of which have the same result.

I can PM you more details if you want to take a look for yourself...

0 vote
Joseph Clark Atlassian Team Feb 26, 2013

OK, try running "netstat -a -n -b" on your Windows server after starting Confluence/Tomcat, which will show you all active TCP listeners on your server. Make sure that the tomcat.exe process has successfully bound to the correct IP address and port. Eg, you should see something like this in the output:

Proto Local Address Foreign Address State RpcSs
TCP 192.30.160.176:80 0.0.0.0:0 LISTENING [tomcat.exe]

Assuming that's all good, try opening TCP Port 80 from a remote server using the telnet command. This will check that the port is actually accessible externally. Run "telnet 192.30.160.176 80" from a bash prompt, and you should get a telnet prompt if it connects successfully. Eg.

jclark@bluetongue ~
$ telnet 192.168.70.35 80
Trying 192.168.70.35...
Connected to 192.168.70.35.
Escape character is '^]'.

I assume that one of these two commands will fail, and we can dig further from there :)

Thanks Joseph finally managed to track it down. Looks like there was an SMS service that was hogging port 80 on that IP address. It also looks like the firewall was still playing a part even though I had issued the command stated above to stop it. Once I killed both of these it all started working.
0 vote
Joseph Clark Atlassian Team Feb 26, 2013

Nice! Glad we got to the bottom of it :)

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published 3 hours ago in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

55 views 4 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you