Service Desk Automation Fails with Custom Field

I'm using JIRA SD automation to transition a linked issue based on previous status. The custom field I've created does show the correct value for previous state, but when I put in the IF statement;

"CustomField" !~ "State" 

It accepts the statement, but doesn't actually do anything when the condition occurs.

1 answer

1 accepted

This widget could not be displayed.
Susan Hauth Community Champion Sep 20, 2017

Did you check the log on the automation to see if it failed?

No errors are showing for it in the logs

Found the solution, there was a condition in the workflow for the transition I was trying to trigger that was blocking it. JSU function that should have hidden it only from the user also prevented it from working. JMWE version works fine though.

Susan Hauth Community Champion Sep 20, 2017

Great....mark this as answered, and it's a great reminder that the automation of workflow transitions will still respect any conditions that are in the workflows.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted yesterday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

52 views 1 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you